summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2019-04-19 15:45:58 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-05-23 16:12:00 +0700
commitd97057b273ef07270cef7bc2845670c545b330ab (patch)
treec5c22301b7e33107b7030e7dbe82a515dbed2801 /meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
parent55c33ce0a852710bf68e515f992f954b2b8c171b (diff)
rcar-gen3: optee-os: Fix GCC 8.x compilation warnings
This commit adds a fix patch from optee-os upstream [1] to fix GCC 8.x compilation warnings with -Wcast-function-type. [1] OPTEE-OS rev: f6d17e33e7b95c90a2521cfd37cd5cb511909fc4 Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 8c1b18d..c129b50 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -21,6 +21,7 @@ SRC_URI = " \
git://github.com/renesas-rcar/optee_os.git;branch=${BRANCH};name=renesas \
git://github.com/OP-TEE/optee_os.git;branch=master;name=officialgit;destsuffix=git_official \
file://0001-core-crypto-arm64-ce-update-AES-CBC-routines.patch;patchdir=../git_official \
+ file://0001-core-define-syscall_t-as-void-void.patch \
"
COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|m3nulcb|ebisu)"
@@ -45,7 +46,7 @@ do_configure() {
}
do_compile() {
- oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y NOWERROR=1
+ oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y
}
# do_install() nothing