summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2019-07-22 14:19:28 +0700
committerKhang Nguyen <khang.nguyen.xw@renesas.com>2019-07-31 15:18:51 +0700
commit5a37497d6e0d33c6ae4f64cf38aa9541b527c883 (patch)
tree0cd49aa4defb94d0ebf38f03ea5e313c92fbfe48 /meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
parent4cc6113c281a2744b1db7669b141a4c60b04ed2a (diff)
rcar-gen3: optee-os: Another fix for git configuration in do_configure
This reverts commit 55c33ce0a852710bf68e515f992f954b2b8c171b and adds '-n' flag to cherry-pick command to avoid the git configuration issue in do_configure, it is simpler and easier than applying patch solution. Change-Id: I62e4d3c262bebb57e1e5f3d792c911aa520be675 Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index f6ac5e5..aeea185 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -20,7 +20,6 @@ SRCREV_FORMAT = "renesas_officialgit"
SRC_URI = " \
git://github.com/renesas-rcar/optee_os.git;branch=${BRANCH};name=renesas \
git://github.com/OP-TEE/optee_os.git;branch=master;name=officialgit;destsuffix=git_official \
- file://0001-core-crypto-arm64-ce-update-AES-CBC-routines.patch;patchdir=../git_official \
file://0001-core-define-syscall_t-as-void-void.patch \
"
@@ -42,6 +41,8 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "-e MAKEFLAGS="
do_configure() {
+ git -C ${WORKDIR}/git_official checkout -B official 3.1.0
+ git -C ${WORKDIR}/git_official cherry-pick -n ${SRCREV_officialgit}
cp -rn ${WORKDIR}/git_official/core/lib/libtomcrypt ${B}/core/lib/.
}