summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-27 11:46:52 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-03 11:10:04 +0200
commit3eab38b3dfc78c6328686226a6a96bdec45bf80a (patch)
tree9fe34022e2b4caa0f840b49d3e3baaa68d1f7e81 /meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb
parent10d0d2392d64bed9aee6f81818390ea5ddd54082 (diff)
[COMMUNITY] sync wayland from upstream
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb')
-rw-r--r--meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb b/meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb
new file mode 100644
index 0000000..291cd16
--- /dev/null
+++ b/meta-rcar-gen3/recipes-forward-port/wayland_fp_morty/weston-init.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+
+SRC_URI = "file://init \
+ file://weston.service \
+ file://weston-start"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
+ install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+
+ # Install weston-start script
+ install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
+ sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
+ sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start
+}
+
+inherit allarch update-rc.d distro_features_check systemd
+
+# rdepends on weston which depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+RDEPENDS_${PN} = "weston kbd"
+
+INITSCRIPT_NAME = "weston"
+INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
+
+SYSTEMD_SERVICE_${PN} = "weston.service"