aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-18 15:45:28 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commit12e83a2162d0b3dfea874042d395a48fd798a19f (patch)
tree81614210a956e300c96dc80e6d6feb3f1d1dd79d /meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
parent6bafe741c94ca9ef335ec175ed2c85c624a49bc3 (diff)
rcar-gen3: libdrm: Change to use v2.4.85
mesa v17.1.1 only supports libdrm from 2.4.75 and later, so we set PREFERRED_VERSION_libdrm in board config to use libdrm v2.4.85 from poky to prevent configure error. | checking for libdrm >= 2.4.75... no | checking for glproto >= 1.4.14... yes | configure: error: Direct rendering requires libdrm >= 2.4.75 | NOTE: The following config.log files may provide further information. | NOTE: /build/tmp/work/aarch64-poky-linux/mesa/2_17.1.1-r0/build/config.log | ERROR: configure failed Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb')
-rw-r--r--meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb b/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
new file mode 100644
index 0000000..4e3e8ef
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Userspace interface to the kernel DRM services"
+DESCRIPTION = "The runtime library for accessing the kernel DRM services. DRM \
+stands for \"Direct Rendering Manager\", which is the kernel portion of the \
+\"Direct Rendering Infrastructure\" (DRI). DRI is required for many hardware \
+accelerated OpenGL drivers."
+HOMEPAGE = "http://dri.freedesktop.org"
+SECTION = "x11/base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
+PROVIDES = "drm"
+DEPENDS = "libpthread-stubs libpciaccess"
+
+SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
+ file://installtests.patch \
+ file://fix_O_CLOEXEC_undeclared.patch \
+ file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \
+ "
+
+SRC_URI[md5sum] = "7aa540aeea4a1f3d1e9b0828f1772543"
+SRC_URI[sha256sum] = "64e4cd87eaee38ae60b2984ef02b66159b9bdd33030040db2a04339cf15f6173"
+
+inherit autotools pkgconfig manpages
+
+EXTRA_OECONF += "--disable-cairo-tests \
+ --without-cunit \
+ --enable-omap-experimental-api \
+ --enable-etnaviv-experimental-api \
+ --enable-install-test-programs \
+ --disable-valgrind \
+ "
+PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
+
+ALLOW_EMPTY_${PN}-drivers = "1"
+PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
+ ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu \
+ ${PN}-etnaviv"
+
+RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
+ ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu \
+ ${PN}-etnaviv"
+
+FILES_${PN}-tests = "${bindir}/*"
+FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*"
+FILES_${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*"
+FILES_${PN}-omap = "${libdir}/libdrm_omap.so.*"
+FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"
+FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
+FILES_${PN}-kms = "${libdir}/libkms*.so.*"
+FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
+FILES_${PN}-amdgpu = "${libdir}/libdrm_amdgpu.so.*"
+FILES_${PN}-etnaviv = "${libdir}/libdrm_etnaviv.so.*"