summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-23 16:26:34 +0100
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-08-25 08:42:50 +0700
commit03fb4ddaf6446f57fab4b0a041723b1ed8c6cebb (patch)
treeeeb2ee6230f80316fb0a3723d3bc45fbcd534bb5 /meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
parent23a3ef7ea1b7c2e1f27c09c2667d127ea827d1bf (diff)
rcar-gen3: mesa: Rename mesa bbappend
This commit renames mesa bbappend to be able to compatible with different mesa versions. Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> (cherry picked from commit 4849eff67419793fd79894fe0002278d09f91e07)
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..e1b7ad2
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,10 @@
+require include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc