aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-23 16:26:34 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-03 11:10:04 +0200
commita3c8f0698fd636e90f44b58ee203e253f9b17a47 (patch)
tree62e9c3a6ef56e43e7f27bafe58dde5d29b34107b /meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
parent2615c7a160e5d3b152410faebc367a621b7e2b47 (diff)
[COMMUNITY] Renamed mesa recipes
* allow compatibility with mesa 12 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..e1b7ad2
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,10 @@
+require include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc