aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2019-06-20 16:18:28 +0700
committerKhang Nguyen <khang.nguyen.xw@renesas.com>2019-09-24 08:16:21 +0700
commitbc759aebc054b4768e2bc516de466fa9c7ce0bb5 (patch)
tree0bebf0d3ce865d1703d7ab14be79d8ce709ee2c5 /meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
parent1feca724cafb604db9075d9b640785a1d96758f3 (diff)
rcar-gen3: weston: Update to support weston 6.0
This commit uses the weston upstream version 6.0 with "GPU only" h/w acceleration. It also modifies weston-init to adapt upstream version. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: I7aabf0f3fcfec0dece05161529bd9eaf401dfbdb
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
new file mode 100644
index 0000000..179651b
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
@@ -0,0 +1,34 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI = " \
+ file://weston.ini \
+ file://weston.sh \
+"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/xdg/weston
+ # install weston.ini as sample settings of gl-renderer
+ install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
+
+ # Checking for ivi-shell configuration
+ # If ivi-shell is enable, we will add its configs to weston.ini
+ if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
+ sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
+ ${D}/${sysconfdir}/xdg/weston/weston.ini
+ sed -e '$a\\' \
+ -e '$a\[ivi-shell]' \
+ -e '$a\ivi-module=ivi-controller.so' \
+ -e '$a\ivi-input-module=ivi-input-controller.so' \
+ -e '$a\transition-duration=300' \
+ -e '$a\cursor-theme=default' \
+ -i ${D}/${sysconfdir}/xdg/weston/weston.ini
+ fi
+
+ # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN}_append = " \
+ ${sysconfdir}/profile.d/weston.sh \
+"