summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
diff options
context:
space:
mode:
authorTakamitsu Honda <takamitsu.honda.pv@renesas.com>2017-01-27 11:47:06 +0900
committerTakamitsu Honda <takamitsu.honda.pv@renesas.com>2017-01-27 11:47:06 +0900
commit3613b2780a6b5d5d70ea6802be5060a8214cbdb5 (patch)
treefab60ccb7b38da7e8558a2879885f06e5b0662d2 /meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
Renesas BSP v3.5.1 (kernel v4.9 stable) [Environment] poky: yocto-2.1.2 (cca8dd15c8096626052f6d8d25ff1e9a606104a3) meta-openembedded: 55c8a76da5dc099a7bc3838495c672140cedb78e meta-linaro: 2f51d38048599d9878f149d6d15539fb97603f8f [Information] - U-boot: Changed load address from H'49000000 to H'50000000 - XDG_RUNTIME_DIR has been changed from "/run/user/root" to "/run/user/0" - Change location of include directory, which stores common user header files, to $(INCSHARED) - In BSP Only, core-image-weston is not supported even though local-wayland.conf is provided. - Please set Salvator-x SW7 Pin-1. In after Yocto BSP v2.12.0, it is  necessary to enable BKUP_TRG signal for Suspend to RAM. - The dtb filename was changed in R-Car H3. Only "Image-r8a7795-es1-salvator-x.dtb" is supported in this version. Please use "Image-r8a7795-es1-salvator-x.dtb" It supports R-Car H3 WS1.0 and WS1.1. - Please update your local.conf and bblayers.conf corresponding to Yocto v2.16.0 package. You can refer to meta-rcargen3/docs/sample/conf/ for updated contents. - You have to re-compile out-of-recipe software like user application by v2.16.0 SDK toolchains. - In some boards, the resuming from System Suspend to RAM may cause unstable operation or failed to resume. Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
new file mode 100644
index 0000000..48e49dc
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
@@ -0,0 +1,44 @@
+require weston.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+BRANCH = "rcar-gen3/1.11.0/gl-fallback"
+
+SRCREV = "ef4fdad7fc6549493c244b6e657ec00565408497"
+
+SRC_URI = " \
+ git://github.com/renesas-rcar/weston.git;branch=${BRANCH} \
+ file://weston.png \
+ file://weston.desktop \
+ file://0001-make-error-portable.patch \
+ file://0001-configure.ac-Fix-wayland-protocols-path.patch \
+ file://0001-shared-include-stdint.h-for-int32_t.patch \
+ file://xwayland.weston-start \
+ file://make-weston-launch-exit-for-unrecognized-option.patch \
+ file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
+ file://weston.ini \
+ file://weston_v4l2.ini \
+"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG_append = " \
+ ${@base_conditional('USE_MULTIMEDIA', '1', ' v4l2', '', d)} \
+"
+PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"
+
+do_install_append() {
+ if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
+ # install weston.ini as sample settings of v4l2-renderer
+ install -d ${D}/${sysconfdir}/xdg/weston
+ install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
+ else
+ # install weston.ini as sample settings of gl-renderer
+ install -d ${D}/${sysconfdir}/xdg/weston
+ install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
+ fi
+}
+
+FILES_${PN}_append = " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+"