aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-07-24 17:54:57 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-15 10:20:15 +0200
commite493fb8edc4d3acb1d3ff7822ef5af3f0ca794df (patch)
tree7ecf0e3991f087f9486f08080ce22f470c561aa1 /meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
parentbf28a005deaa3ce5d6c5d43d233822983b859cf4 (diff)
wayland: use poky meta wayland/weston
Support for Weston 2.0 will appear in the Renesas Weston implementation in an upcoming Yocto BSP release. Until it appears use the upstream reference implementation in Poky Meta, with "GPU only" h/w acceleration. Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend60
1 files changed, 0 insertions, 60 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
deleted file mode 100644
index fc41252..0000000
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ /dev/null
@@ -1,60 +0,0 @@
-require weston.inc
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-BRANCH = "rcar-gen3/1.11.0/gl-fallback"
-
-SRCREV = "68d84325d3b7ef0612f79e8280b91c4a1a6dfebc"
-
-SRC_URI = " \
- git://github.com/renesas-rcar/weston.git;branch=${BRANCH} \
- file://weston.png \
- file://weston.desktop \
- file://0001-make-error-portable.patch \
- file://0001-configure.ac-Fix-wayland-protocols-path.patch \
- file://0001-shared-include-stdint.h-for-int32_t.patch \
- file://xwayland.weston-start \
- file://make-weston-launch-exit-for-unrecognized-option.patch \
- file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
- file://weston.ini \
- file://weston_v4l2.ini \
-"
-
-S = "${WORKDIR}/git"
-
-PACKAGECONFIG_append = " \
- ${@base_conditional('USE_MULTIMEDIA', '1', ' v4l2', '', d)} \
-"
-PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/xdg/weston
- if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
- # install weston.ini as sample settings of v4l2-renderer
- if [ "${MACHINE}" = "m3ulcb" -o "${MACHINE}" = "h3ulcb" ] ; then
- sed -i 's|media1|media0|g' ${WORKDIR}/weston_v4l2.ini
- fi
- install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
- else
- # install weston.ini as sample settings of gl-renderer
- install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
- fi
-
- # Checking for ivi-shell configuration
- # If ivi-shell is enable, we will add its configs to weston.ini
- if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
- sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
- ${D}/${sysconfdir}/xdg/weston/weston.ini
- sed -e '$a\\' \
- -e '$a\[ivi-shell]' \
- -e '$a\ivi-module=ivi-controller.so' \
- -e '$a\ivi-input-module=ivi-input-controller.so' \
- -e '$a\transition-duration=300' \
- -e '$a\cursor-theme=default' \
- -i ${D}/${sysconfdir}/xdg/weston/weston.ini
- fi
-}
-
-FILES_${PN}_append = " \
- ${sysconfdir}/xdg/weston/weston.ini \
-"