summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/kernel-module-gles
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-05 13:42:50 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:07:59 +0700
commit719941576c5b957c06b1f3dfc89173cdc466721d (patch)
tree8825fd1d1a388ef44aaa717af576ebaa47be2654 /meta-rcar-gen3/recipes-kernel/kernel-module-gles
parent2f4d16e6e7db9d0e702872cb2ffd008419a6bdfa (diff)
rcar-gen3: kernel-module: Set KERNEL_MODULE_PACKAGE_SUFFIX to fix building kernel modules
From YP2.3 [1], kernel module packages are now suffixed with the kernel version in order to allow module packages from multiple kernel versions to co-exist on a target system. We can return to the previous naming scheme that does not include the version suffix by setting KERNEL_MODULE_PACKAGE_SUFFIX to blank to build modules without suffix. [1] http://www.yoctoproject.org/docs/2.3/ref-manual/ref-manual.html#migration-2.3-miscellaneous-changes Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/kernel-module-gles')
-rw-r--r--meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb b/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
index b2a1274..8dea6a3 100644
--- a/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
+++ b/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
@@ -29,6 +29,9 @@ B = "${KBUILD_DIR}"
EXTRA_OEMAKE = "KERNELDIR=${STAGING_KERNEL_BUILDDIR}"
EXTRA_OEMAKE += "CROSS_COMPILE=${CROSS_COMPILE}"
+# Build GFX kernel module without suffix
+KERNEL_MODULE_PACKAGE_SUFFIX = ""
+
module_do_compile() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
cd ${KBUILD_DIR}