aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-20 14:55:18 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-12-19 15:23:55 +0700
commit0814c5cebd418b10a24b11e22ae08a84324d0f27 (patch)
treeebbd74ba4f5601ce202f057abf19d0d99d4a48db /meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch
parent98f4f5ec2c9bc4ab03d430e9cdcb4b7591a64dcd (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.9.2
This commit upgrades Linux BSP to v3.9.2 for the following changes: [Kernel] - Add support for RCKSEL clock selection. - Fix pin functions of R-Car E3 according to H/W UM Rev1.00 errata. - Fix warning of the make W=1 C=2. - Identify R-Car M3 Ver.1.3. - Add the big.LITTLE CAS scheduler fix patches. - Fix MOD_SEL bit numbering for R-Car E3. [Power Management] - Fixup power-domains of 3DGE for R-Car E3 Ver.1.0 and add device tree file for R-Car E3 Ver.1.0. [Audio Driver] - Fixup clock start checker. - Resolve the problem that the noise is generated during long playback with R-Car E3 Ebisu-4D board by kernel rebasing. [Display Driver] - Add function of suspend and resume to adv7511_drv.c and add hot plug event function at resume in rcar_du_drv.c. - Add depends on DRM_RCAR_DU to config DRM_RCAR_LVDS. - Revert "drm: rcar-du: Fix legacy DT to create LVDS encoder nodes". - Add clock function for LVDS PLL. [Ethernet Driver] - Decrease TxFIFO depth of Q3 and Q2 to one. - Fix not to call phy_resume() if PHY is not attached and add toggling phy reset if PHY is not attached. - Revert "ravb: RX checksum offload" for communicating of Q-Tag VLAN frame correctly. - Resolved the problem that the S2RAM resume failed on R-Car E3 Ebisu-4D by kernel rebasing. - Avoid unsupported internal delay mode for R-Car E3 and limit to 100Mbps. [I2C Driver] - Check bus state before reinitializing. [IPMMU Driver] - Fix crash on early domain free. - Revert "arm64: defconfig: Enable QCOM_IOMMU" for suspending with LTSI kernel. - Correct whitelist devices assignment. [PCIe Driver] - Avoid PCI device removing/rescanning through sysfs triggers a deadlock. [PWM Driver] - Avoid deadlock warning when removing PWM device. [SD/MMC Driver] - Fix card initialization failure in high speed mode. - Add adjust HS400 offset by manual calibration mode and adjust HS400 offset by manual calibration mode for R-Car M3 Ver.1.3. [USB2.0 Function] - Add reset_control. - Backport upstream patches to support OTG mode for R-Car E3. - Make DMAC system sleep callbacks explicit. - Add Super-Speed (b-device) support. [Video Capture driver] - Review adv748x driver for R-Car E3 Ebisu board and add option for changing SD output route to TXA. - Revert "rcar-vin: rcar-csi2: Add blank margin when caluculating bit rate" and fix pixel rate values. - Add CPG reset and release when using digital pin. [RWDT Driver] - Don't keep timer value during suspend/resume. - Don't set divider while watchdog is running. This also updates ADSP driver patches to adapt to the new Linux version. Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xv@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch
new file mode 100644
index 0000000..ecab412
--- /dev/null
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/0003-ADSP-add-build-for-ADSP-sound-driver.patch
@@ -0,0 +1,35 @@
+From 3ae5cb9feda031f660becc94f5496d5ee9b90e22 Mon Sep 17 00:00:00 2001
+From: tienphitran <tien.tran.uw@renesas.com>
+Date: Mon, 15 Oct 2018 17:57:56 +0700
+Subject: [PATCH 3/6] ADSP: add build for ADSP sound driver
+
+Signed-off-by: tienphitran <tien.tran.uw@renesas.com>
+---
+ sound/soc/Kconfig | 1 +
+ sound/soc/Makefile | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/sound/soc/Kconfig b/sound/soc/Kconfig
+index c0abad2067e1..f5f6abbd6e14 100644
+--- a/sound/soc/Kconfig
++++ b/sound/soc/Kconfig
+@@ -71,6 +71,7 @@ source "sound/soc/txx9/Kconfig"
+ source "sound/soc/ux500/Kconfig"
+ source "sound/soc/xtensa/Kconfig"
+ source "sound/soc/zte/Kconfig"
++source "sound/soc/adsp/Kconfig"
+
+ # Supported codecs
+ source "sound/soc/codecs/Kconfig"
+diff --git a/sound/soc/Makefile b/sound/soc/Makefile
+index bf8c1e2ce0bf..6e77abba2b01 100644
+--- a/sound/soc/Makefile
++++ b/sound/soc/Makefile
+@@ -52,3 +52,4 @@ obj-$(CONFIG_SND_SOC) += txx9/
+ obj-$(CONFIG_SND_SOC) += ux500/
+ obj-$(CONFIG_SND_SOC) += xtensa/
+ obj-$(CONFIG_SND_SOC) += zte/
++obj-$(CONFIG_SND_SOC) += adsp/
+--
+2.19.1
+