summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-12-23 11:16:02 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commitf86189b4063883c3fb50bc4561960515feff836f (patch)
tree5079c634189a48f94bd5c8dfe6b581224829077c /meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
parent7acbf5e2f99c59478adbc73c6a40d314589a3009 (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.6.0
This commit upgrades Linux BSP to v3.6.0 for supporting Kernel v4.14 stable and updating following items: [Kernel] - Add support for WDIOF_CARDRESET. [Power Management] - Add missing iounmap to rcar_avs.c. - Add big.LITTLE CAS support. - Add CA53 CPUIdle support. - Add CA53 EMS support. - Add CA53 CPUFreq support. [Audio driver] - Confirm rmmod command operation of snd-soc-rcar. - Skip disabled-SSI nodes. - Care ssi_parent_mod and remove NULL check from rsnd_mod_name()/rsnd_mod_id(). - Revert IOMMU support so far. - Don't use runtime->sample_bits. - More clear rsnd_get_dalign() for DALIGN. - Clear SSI_MODE for non TDM Extended modes. [Display driver] - Confirm the Fence function. - Add support for colorkey alpha blending. - Disable vsp1 interrupt when startup. [DMA Engine driver] - Fix array-bounds warning refer chcr_ts[]. [PWM driver] - Enable PWM2 in device tree. [USB2.0 Function] - Fix the problem that the interrupt becomes long time when disconnecting the USB cable. [Video Capture driver] - Add V4L2_FIELD_SEQ_TB/BT function support. - Add ARGB8888 caputre format support and overflow debug message option. - Fix cropping procedure. [RWDT driver] - Add support for WDIOF_CARDRESET. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
new file mode 100644
index 0000000..99d23e7
--- /dev/null
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linux kernel for the R-Car Generation 3 based board"
+
+require include/avb-control.inc
+require recipes-kernel/linux/linux-yocto.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
+
+RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
+BRANCH = "v4.14/rcar-3.6.0"
+SRCREV = "cdbdfa1452a86607db4d43914f4953ac811d2c56"
+
+SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"
+
+LINUX_VERSION ?= "4.14.0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+PR = "r1"
+
+SRC_URI_append = " \
+ file://defconfig \
+ file://touch.cfg \
+ ${@base_conditional("USE_AVB", "1", " file://usb-video-class.cfg", "", d)} \
+"