summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-06-11 09:16:50 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-06-18 17:55:58 +0700
commitc38c37303164d16e514236655f629e8d186137ae (patch)
tree2e05582a9af9b2fd40739ae9064c13bb497b8234 /meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
parentc93db19426c1367ffcbc25b777fbab6b5923646c (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.7.0
This commit upgrades Linux BSP to v3.7.0 for following updates: [Kernel] - Change Linux version to v4.14.35 from v4.14. - Add support ZG clock divider for R8A77990 (R-Car E3). - Remove patch for Identifing R-Car M3 Ver.1.2 or later. [Power Management] - Fix "Using plain integer as NULL pointer" in rcar_ems_ctrl.c. - Add AVS support for gsx_opp_table. - Update SYSC power ON/OFF flow. [Display driver] - Fix procedure for extal and dotclkin selection for R-Car E3. - Add shutdown callback function in platform_driver". - Fix state flag in case of dual link mode for R-Car E3. [Ethernet driver] - Move reset-gpios property to EthernetAVB node for R-Car E3 Ebisu board. [I2C driver] - Fix handling of the RESTART phase and STOP phase. [MSIOF driver] - Add 2 clock delay by R-Car H3 Ver.3.0 only specification. [SD/MMC driver] - Fix eMMC HS400 mode setting. - Delete wait in tuning process. [USB2.0 Function] - Avoid wrong list handling in printer_write(). [USB2.0 Host driver] - Avoid the problem of Suspend to RAM in case of connecting USB mouse by removing following patches: <commit ID:cad25bf1> phy: rcar-gen3-usb2: Add the interrupt disabled in suspend <commit ID:318b535> phy: rcar-gen3-usb2: Support System Suspend To RAM [Video Capture driver] - Fix IFMD table information for R8A77990 (R-Car E3). Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb16
1 files changed, 3 insertions, 13 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 37d812c..ce4e3a5 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -9,12 +9,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.2"
-SRCREV = "a95d91d636e3dcfdb8279a0293da17e90c871186"
+BRANCH = "v4.14/rcar-3.7.0"
+SRCREV = "118adc53e8e9806d76f40859ba96290f289f8839"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"
-LINUX_VERSION ?= "4.14.0"
+LINUX_VERSION ?= "4.14.35"
PV = "${LINUX_VERSION}+git${SRCPV}"
PR = "r1"
@@ -24,16 +24,6 @@ SRC_URI_append = " \
${@base_conditional("USE_AVB", "1", " file://usb-video-class.cfg", "", d)} \
"
-# Patches for sysc
-SRC_URI_append = " \
- file://0001-soc-renesas-rcar-sysc-Update-power-control-flow-for-.patch \
- file://0002-soc-renesas-rcar-sysc-Add-SYSCEXTMASK-info-for-r8a77.patch \
- file://0003-soc-renesas-rcar-sysc-Add-SYSCEXTMASK-info-for-r8a77.patch \
- file://0004-soc-renesas-rcar-sysc-Add-SYSCEXTMASK-info-for-r8a77.patch \
- file://0005-soc-renesas-rcar-sysc-Add-SYSCEXTMASK-info-for-r8a77.patch \
- file://0006-soc-renesas-rcar-sysc-Add-SYSCEXTMASK-info-for-r8a77.patch \
-"
-
# Enable RPMSG_VIRTIO depend on ICCOM
SUPPORT_ICCOM = " \
file://0001-rpmsg-Add-message-to-be-able-to-configure-RPMSG_VIRT.patch \