summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-03-19 08:57:28 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-03-22 13:36:54 +0700
commita6ae66ceba4bebf26f97aa5af720477c816467ec (patch)
tree9504d7bba6205392271639032d73a8600a79ae05 /meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
parent0d9a1348ae1164e45c3f8ee95b8a529314eb0cf9 (diff)
rcar-gen3: linux-renesas: Add support E3 and upgrade Linux BSP to v3.6.1
This commit adds support E3 and upgrades Linux BSP to v3.6.1 for the following updates: [Kernel] - Add R-Car E3 support. - Fix Gfx clock. [Power Management] - Register clock for all cpu nodes for R-Car H3 to device tree. - Improve to build only when enabling RCAR_POWER_AVS. - Update IPA for CA53, need tune "contribution" parameter. - Fix section mismatch build warnings. - Fix double source of drivers/soc/renesas/Kconfig. [Display driver] - Fix continuous mode for dual pipelines. - Fix DISP interrupt enable order, DPPR register set order and LVDS startup sequence. - Fix LVDS startup on R-Car Series, 3rd Generation. - Fix LVDS stop sequence. [DMA Engine driver] - Fix max_chunk_size for R-Car Series, 3rd Generation. - Check the done lists in rcar_dmac_chan_get_residue(). [I2C driver] - Fix the problem that the strange data transfers with DMA transmit. [IPMMU driver] - Fix sequence issue. [SD/MMC driver] - Fix handling of SET_BLOCK_COUNT for RPMB. [USB3.0 Function] - Fix oops in renesas_usb3_remove(). - Don't print a warning when setting link state for disabled ports. [Video Capture driver] - Fix transfer rate and phy register value. Add CPG reset release procedure. - Add bytes per line when opening device. - Fix power management procedure when resuming. - Add MSTP status check after CPG reset. - Fix division procedure for __udivdi3 error. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 31695e0..61f3803 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -4,11 +4,11 @@ require include/avb-control.inc
require recipes-kernel/linux/linux-yocto.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
-COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
+COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.0"
-SRCREV = "cdbdfa1452a86607db4d43914f4953ac811d2c56"
+BRANCH = "v4.14/rcar-3.6.1"
+SRCREV = "4a7e26bdbc8d210369eab25765c277200cd910a8"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"