summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-10-24 14:49:01 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-24 20:14:46 +0700
commit7d135e5c8bc5cc7b3c14ce942383542dbc2ce6e6 (patch)
treee352d66fb0c7ecdb9b345b5cc1ee83eacc177bf5 /meta-rcar-gen3/recipes-kernel/linux
parent38d22e29aad3714b766bad9519efe33b737683ba (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.5.9
Linux BSP has been upgraded for supporting R-Car M3N Ver.1.0 and updating following items: [Kernel] - Add R-Car M3N Ver.1.0 support. - Fix MSIOF3 and VI5_DATA13 pinmux settings. [Audio driver] - Don't check SSISR::DIRQ when Capture. - Call dummy write for PW_MGMT1/3 with AK4613 when Playback. - TDM 6ch needs 8ch clock for hw refine. - Fix pcm-creation regression. [Display driver] - Fix race condition when disabling planes at CRTC stop and add reference counting to drm_atomic_state. - Fix register parameters passed to HDMI. - Unconditionally call prepare_fb and remove drm_atomic_helper_framebuffer_changed. [DMA Engine driver] - Fixup descriptor pointer for descriptor mode and use TCRB instead of TCR for residue. [Ethernet driver] - Fix condition of phy reset. [I2C driver] - Fix I2C DMA reception by adding reset. - Fix I2C DMA transmission by setting sequence. - Fix DMA Callback processing of I2C dma mode. - Fix handling of the STOP phase. [MFISLock driver] - Revert and add support for R-Car Gen3 Hardware Spinlock again. [SD/MMC driver] - Add identification of TAP and clock settings of HS400. - Fix HS400 mode selection process. - Fix SCC error check condition. [USB2.0 Function] - Avoid spinlock recursion. [USB3.0 Function] - Fix for no-data control transfer and fix Pn_RAMMAP.Pn_MPKT value. - Fix return value of usb3_write_pipe(). - The maximum PIPEs change from 30 to 5 except PIPE0 and EP0 by H/W specification’s change. H/W specification is fixed because it has description mistakes. [Video Capture driver] - Remove VnMC setting when setting VnCSI_IFMD. - Fix PHTW register parameter for mbps. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig2
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
index 63c00c8..ea66f58 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
@@ -343,6 +343,7 @@ CONFIG_ARCH_SHMOBILE=y
CONFIG_ARCH_RENESAS=y
CONFIG_ARCH_R8A7795=y
CONFIG_ARCH_R8A7796=y
+CONFIG_ARCH_R8A77965=y
CONFIG_ARCH_STRATIX10=y
CONFIG_ARCH_TEGRA=y
CONFIG_ARCH_SPRD=y
@@ -2367,6 +2368,7 @@ CONFIG_PINCTRL_EXYNOS=y
CONFIG_PINCTRL_SH_PFC=y
CONFIG_PINCTRL_PFC_R8A7795=y
CONFIG_PINCTRL_PFC_R8A7796=y
+CONFIG_PINCTRL_PFC_R8A77965=y
CONFIG_PINCTRL_SUNXI=y
# CONFIG_PINCTRL_SUN4I_A10 is not set
# CONFIG_PINCTRL_SUN5I_A10S is not set
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
index 9207cdd..82b7292 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
@@ -7,8 +7,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.8"
-SRCREV = "bef6058b0ba00238b19e7518ba76536218ef97f1"
+BRANCH = "v4.9/rcar-3.5.9"
+SRCREV = "2c20c9881d53f1b5c7a3ebf55bb83ec15902d0d0"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"