summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-12-26 09:47:51 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commitb53ab08479dfef66f98f2a29ac6f9a5cc47b1433 (patch)
tree7ad6ce4ddeee377fa16bfacd90594046fefca6c0 /meta-rcar-gen3/recipes-kernel
parentadb60b149d50552bd9ac3dbeb5eb693f5bdb4b40 (diff)
rcar-gen3: linux-renesas: Update to enable USB 3.0
This commit modifies recipe to install USB 3.0 firmware to kernel source and to enable USB 3.0 in kernel image. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/usb3.cfg4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb15
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/usb3.cfg b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/usb3.cfg
new file mode 100644
index 0000000..f58b942
--- /dev/null
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/usb3.cfg
@@ -0,0 +1,4 @@
+CONFIG_FW_LOADER=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_EXTRA_FIRMWARE="r8a779x_usb3_v2.dlmem r8a779x_usb3_v3.dlmem"
+CONFIG_EXTRA_FIRMWARE_DIR="firmware"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 9e33ba4..31695e0 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -27,3 +27,18 @@ SRC_URI_append = " \
${@bb.utils.contains('MACHINE_FEATURES','cas','file://capacity_aware_migration_strategy.cfg','',d)} \
"
+# Install USB3.0 firmware to rootfs
+USB3_FIRMWARE_V2 = "https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/r8a779x_usb3_v2.dlmem;md5sum=645db7e9056029efa15f158e51cc8a11"
+USB3_FIRMWARE_V3 = "https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/r8a779x_usb3_v3.dlmem;md5sum=687d5d42f38f9850f8d5a6071dca3109"
+
+SRC_URI_append = " \
+ ${USB3_FIRMWARE_V2} \
+ ${USB3_FIRMWARE_V3} \
+ ${@bb.utils.contains('MACHINE_FEATURES','usb3','file://usb3.cfg','',d)} \
+"
+
+do_download_firmware () {
+ install -m 755 ${WORKDIR}/r8a779x_usb3_v*.dlmem ${STAGING_KERNEL_DIR}/firmware
+}
+
+addtask do_download_firmware after do_configure before do_compile