summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-12-23 12:00:22 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commitc7bf6dd5e219a9066f31debf177e23abe28f13a5 (patch)
tree7b44b0889e99cc46114acd0d63ce965116d8aa20 /meta-rcar-gen3/recipes-kernel
parentca80cc5603eb810c8f47694f553b13ff79060ff1 (diff)
rcar-gen3: IPL: Update IPL version according to BSP v3.6.0
This commit changes following contents: - Update IPL and Secure Monitor Rev1.0.18 rev2 - Update optee_os Rev1.0.11 rev2 Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel')
-rw-r--r--meta-rcar-gen3/recipes-kernel/optee-linuxdriver/optee-linuxdriver_git.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/optee-linuxdriver/optee-linuxdriver_git.bb b/meta-rcar-gen3/recipes-kernel/optee-linuxdriver/optee-linuxdriver_git.bb
deleted file mode 100644
index 642354d..0000000
--- a/meta-rcar-gen3/recipes-kernel/optee-linuxdriver/optee-linuxdriver_git.bb
+++ /dev/null
@@ -1,75 +0,0 @@
-DESCRIPTION = "OP-TEE Linux Driver"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = " \
- file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
-"
-inherit module
-
-PN = "optee-linuxdriver"
-PR = "r0"
-BRANCH = "rcar_gen3"
-SRC_URI = " \
- git://github.com/renesas-rcar/optee_linuxdriver.git;branch=${BRANCH} \
-"
-SRCREV = "3fd77f0dd8a070945f869ec706ebe48fc0d27c20"
-
-PV = "1.1.0+renesas+git${SRCPV}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-S = "${WORKDIR}/git"
-
-LDFLAGS[unexport] = "1"
-
-do_configure[noexec] = "1"
-# We need to be staged before do_complie. This recipe does not execute do_configure.
-do_complile[depends] += "virtual/kernel:do_shared_workdir"
-
-do_compile() {
- # Build kernel module
- cd ${S}/
- make -C ${KBUILD_OUTPUT} M=${S} modules
-}
-
-do_install() {
- # Create shared directories
- install -d ${D}/lib/modules/${KERNEL_VERSION}/extra/
- install -d ${STAGING_KERNEL_DIR}/include
- install -d ${STAGING_KERNEL_DIR}/include/arm_common
- install -d ${STAGING_KERNEL_DIR}/include/linux
-
- # Install kernel module
- install -m 0644 ${S}/core/optee.ko ${D}/lib/modules/${KERNEL_VERSION}/extra/
- install -m 0644 ${S}/armtz/optee_armtz.ko ${D}/lib/modules/${KERNEL_VERSION}/extra/
-
-
- # Install shared library to STAGING_KERNEL_DIR for reference from other modules
- # This file installed in SDK by kernel-devsrc pkg.
- install -m 0644 ${S}/Module.symvers ${STAGING_KERNEL_DIR}/include/optee.symvers
-
- # Install shared header files to STAGING_KERNEL_DIR
- # This file installed in SDK by kernel-devsrc pkg.
- install -m 0644 ${S}/include/arm_common/optee_msg.h ${STAGING_KERNEL_DIR}/include/arm_common/
- install -m 0644 ${S}/include/arm_common/optee_smc.h ${STAGING_KERNEL_DIR}/include/arm_common/
- install -m 0644 ${S}/include/linux/tee_client_api.h ${STAGING_KERNEL_DIR}/include/linux/
- install -m 0644 ${S}/include/linux/tee_core.h ${STAGING_KERNEL_DIR}/include/linux/
- install -m 0644 ${S}/include/linux/tee_ioc.h ${STAGING_KERNEL_DIR}/include/linux/
- install -m 0644 ${S}/include/linux/tee_kernel_api.h ${STAGING_KERNEL_DIR}/include/linux/
-}
-
-PACKAGES = "\
- ${PN} \
- ${PN}-armtz \
-"
-
-FILES_${PN} = " \
- /lib/modules/${KERNEL_VERSION}/extra/optee.ko \
-"
-
-FILES_${PN}-armtz = " \
- /lib/modules/${KERNEL_VERSION}/extra/optee_armtz.ko \
-"
-
-RPROVIDES_${PN} += "optee-linuxdriver"
-RPROVIDES_${PN} += "kernel-module-optee"
-RPROVIDES_${PN} += "kernel-module-optee-armtz"