aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-10-24 16:15:15 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-24 20:15:52 +0700
commitbe71e972ba37c02bd6bbd66500f8173b3c775b04 (patch)
tree2eb0038d567c714bfabe9f90ebae39e23a259c4d /meta-rcar-gen3/recipes-kernel
parent2ffae4f6b2ad41f0e4a8a8ab114636370f3f0413 (diff)
rcar-gen3: GFX: Update to support M3N board
This commit modifies graphic recipes to support M3N GFX version. It also updates copyscript to support copying M3N GFX packages. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel')
-rw-r--r--meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb b/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
index bdfd0a8..b2a1274 100644
--- a/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
+++ b/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bb
@@ -8,17 +8,21 @@ inherit module
PN = "kernel-module-gles"
PR = "r0"
-COMPATIBLE_MACHINE = "(r8a7795|r8a7796)"
+COMPATIBLE_MACHINE = "(r8a7795|r8a7796|r8a77965)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI_r8a7795 = 'file://GSX_KM_H3.tar.bz2'
SRC_URI_r8a7796 = 'file://GSX_KM_M3.tar.bz2'
+SRC_URI_r8a77965 = 'file://GSX_KM_M3N.tar.bz2'
+
S = "${WORKDIR}/rogue_km"
KBUILD_DIR_r8a7795 = "${S}/build/linux/r8a7795_linux"
KBUILD_DIR_r8a7796 = "${S}/build/linux/r8a7796_linux"
+KBUILD_DIR_r8a77965 = "${S}/build/linux/r8a77965_linux"
KBUILD_OUTDIR_r8a7795 = "binary_r8a7795_linux_release/target_aarch64/kbuild/"
KBUILD_OUTDIR_r8a7796 = "binary_r8a7796_linux_release/target_aarch64/kbuild/"
+KBUILD_OUTDIR_r8a77965 = "binary_r8a77965_linux_release/target_aarch64/kbuild/"
B = "${KBUILD_DIR}"