summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2019-02-19 16:07:16 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commit73716ce27ed60f5b470fca2e502ba4770b9d0ef4 (patch)
tree3e90a486c6919ba5f051ff80d165a59d070d0d90 /meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb
parent45a75eda120b6e27ea8c2c42f54442abde710cb9 (diff)
rcar-gen3: gstreamer: Upgrade gstreamer to v1.14.2
Gstreamer upstream has been upgraded to 1.14.2 in YP2.6. This commit also upgrades renesas rcar gstreamer recipes to follow upstream version. Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb
new file mode 100644
index 0000000..e05cbb4
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugin-vspfilter_1.0.1.bb
@@ -0,0 +1,52 @@
+SUMMARY = "GStreamer VSP filter plugin"
+SECTION = "multimedia"
+LICENSE = "GPLv2+"
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base pkgconfig"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
+inherit autotools pkgconfig
+
+PN = "gstreamer1.0-plugin-vspfilter"
+
+EXTRA_AUTORECONF_append = " -I ${STAGING_DATADIR}/aclocal"
+
+VSPFILTER_CONF_r8a7795 = "gstvspfilter-${MACHINE}_r8a7795.conf"
+VSPFILTER_CONF_r8a7796 = "gstvspfilter-${MACHINE}_r8a7796.conf"
+VSPFILTER_CONF_r8a77965 = "gstvspfilter-${MACHINE}_r8a77965.conf"
+VSPFILTER_CONF_r8a77990 = "gstvspfilter-${MACHINE}_r8a77990.conf"
+
+SRC_URI = " \
+ git://github.com/renesas-rcar/gst-plugin-vspfilter.git;branch=RCAR-GEN3/1.0.1 \
+ file://${VSPFILTER_CONF} \
+"
+
+SRCREV = "71459157b4a39821713ccbf3563fe0c0e2003c57"
+
+S = "${WORKDIR}/git"
+
+# submodule is extracted before do_populate_lic
+addtask do_init_submodule after do_unpack before do_patch
+
+do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
+ cd ${S}
+ git submodule init
+ git submodule update
+}
+
+FILES_${PN} = " \
+ ${libdir}/gstreamer-1.0/libgstvspfilter.so \
+ ${sysconfdir}/gstvspfilter.conf"
+FILES_${PN}-dev = "${libdir}/gstreamer-1.0/libgstvspfilter.la"
+FILES_${PN}-staticdev = "${libdir}/gstreamer-1.0/libgstvspfilter.a"
+FILES_${PN}-dbg = " \
+ ${libdir}/gstreamer-1.0/.debug \
+ ${prefix}/src"
+
+do_install_append() {
+ install -Dm 644 ${WORKDIR}/${VSPFILTER_CONF} ${D}/etc/gstvspfilter.conf
+}
+
+RDEPENDS_${PN} = "kernel-module-vsp2driver"