summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2019-02-19 16:07:16 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commit73716ce27ed60f5b470fca2e502ba4770b9d0ef4 (patch)
tree3e90a486c6919ba5f051ff80d165a59d070d0d90 /meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend
parent45a75eda120b6e27ea8c2c42f54442abde710cb9 (diff)
rcar-gen3: gstreamer: Upgrade gstreamer to v1.14.2
Gstreamer upstream has been upgraded to 1.14.2 in YP2.6. This commit also upgrades renesas rcar gstreamer recipes to follow upstream version. Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend
new file mode 100644
index 0000000..3ac5977
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.%.bbappend
@@ -0,0 +1,32 @@
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz"
+SRC_URI_append = " git://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.14.2"
+
+SRCREV = "1cfab18912d9ab3f9dd38896f8d6057ac38ededc"
+
+DEPENDS += "mmngrbuf-user-module"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF_append = " \
+ --enable-cont-frame-capture \
+ --enable-ignore-fps-of-video-standard \
+"
+
+# submodule is extracted before do_populate_lic
+addtask do_init_submodule after do_unpack before do_patch
+
+do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
+ cd ${S}
+ git submodule init
+ git submodule update
+}
+
+do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh --noconfigure
+ cd ${B}
+}