summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/open-avb
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-09-11 13:43:43 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:07:59 +0700
commit4d30aff043f28e62d0387beea8234252cb81d8f5 (patch)
tree39e5e431f16e1152a9fa82c54bfc8ce00a5c616b /meta-rcar-gen3/recipes-multimedia/open-avb
parent3e0aa5e9279916634796f8a51018a202590af2f2 (diff)
rcar-gen3: open-avb: Update SRCREV to follow latest version
This commit modifies SRCREV of open-avb to follow upstream repository name/URL change. It also adds 2 patches to fix compile error and QA issues. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Masaru Nagai <masaru.nagai.vx@renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/open-avb')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/open-avb/open-avb/0001-Fix-QA-issue-when-build-with-Yocto.patch34
-rw-r--r--meta-rcar-gen3/recipes-multimedia/open-avb/open-avb_git.bb16
2 files changed, 44 insertions, 6 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb/0001-Fix-QA-issue-when-build-with-Yocto.patch b/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb/0001-Fix-QA-issue-when-build-with-Yocto.patch
new file mode 100644
index 0000000..dbc1ecc
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb/0001-Fix-QA-issue-when-build-with-Yocto.patch
@@ -0,0 +1,34 @@
+From 5e9eff188ada13e1c1986d5611a42e0779fe7fd1 Mon Sep 17 00:00:00 2001
+From: Thao Nguyen <thao.nguyen.yb@renesas.com>
+Date: Mon, 18 Sep 2017 17:09:21 +0700
+Subject: [PATCH] Fix QA issue when build with Yocto
+
+Yocto project has updated Linker Hash Style Changed in YP2.4.
+Makefile should be updated to avoid QA error.
+
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/proj/yocto/gen3/v3.4.0-pt2/build/tmp/work/aarch64-poky-linux/open-avb/1.1+gitAUTOINC+5e43fa5ae2-r0/packages-split/open-avb-gptp/usr/bin/daemon_cl' [ldflags]
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: Function failed: do_package_qa
+
+Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com>
+Signed-off-by: Masaru Nagai <masaru.nagai.vx@renesas.com>
+---
+ daemons/gptp/linux/build/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/daemons/gptp/linux/build/Makefile b/daemons/gptp/linux/build/Makefile
+index 1e00b1a..99fbf84 100644
+--- a/daemons/gptp/linux/build/Makefile
++++ b/daemons/gptp/linux/build/Makefile
+@@ -131,7 +131,7 @@ LDFLAGS_G += -lpthread -lrt
+
+ CFLAGS = $(CFLAGS_G)
+ CPPFLAGS = $(CPPFLAGS_G)
+-LDFLAGS = $(LDFLAGS_G)
++LDFLAGS += $(LDFLAGS_G)
+
+ all: $(OBJ_DIR)/daemon_cl
+
+--
+1.9.1
+
diff --git a/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb_git.bb b/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb_git.bb
index eeb3aa9..c4f71b4 100644
--- a/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb_git.bb
+++ b/meta-rcar-gen3/recipes-multimedia/open-avb/open-avb_git.bb
@@ -1,12 +1,13 @@
-DESCRIPTION = "Open AVB - an AVnu sponsored repository for Audio/Video Bridging technology"
-HOMEPAGE = "https://github.com/AVnu/Open-AVB"
+DESCRIPTION = "OpenAvnu - an AVnu sponsored repository for Time Sensitive Network (TSN and AVB) technology"
+HOMEPAGE = "https://github.com/AVnu/OpenAvnu"
LICENSE = "BSD & MIT & GPLv2 & LGPLv2"
LIC_FILES_CHKSUM = " \
file://daemons/LICENSE;md5=81ccd62d4bc28bafc5e1a2576536b927 \
+ file://daemons/shaper/LICENSE;md5=53e60f7a40864e4c075831415f2ecc59 \
file://kmod/igb/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://kmod/igb/LICENSE;md5=e2c0cd0820d168b0b26e19f13df4dc56 \
file://lib/igb/LICENSE;md5=9bc783ca40be823a8b237df5eed80fc4 \
- file://lib/avtp_pipeline/LICENSE;md5=8f7b370a91d698ed80d2d20e8e01fbb6 \
+ file://lib/avtp_pipeline/LICENSE;md5=485c2c585be88b59c3ee70a016f27959 \
file://examples/LICENSE;md5=81ccd62d4bc28bafc5e1a2576536b927 \
file://examples/gstreamer-avb-plugins/COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://examples/gstreamer-avb-plugins/COPYING.MIT;md5=bba6cdb9c2b03c849ed4975ed9ed90dc \
@@ -16,8 +17,11 @@ DEPENDS = "libpcap"
PV = "1.1+git${SRCPV}"
-SRCREV = "bfa7f9d0c5c8ffe1c0248c6415b3f94e8b7f10c5"
-SRC_URI = "git://github.com/AVnu/Open-AVB.git;branch=open-avb-next"
+SRCREV = "5e43fa5ae27fbd2b89c320670a32143ce93e0e16"
+SRC_URI = "git://github.com/AVnu/OpenAvnu.git;branch=master"
+
+# Fix QA issue of ldflags
+SRC_URI_append = " file://0001-Fix-QA-issue-when-build-with-Yocto.patch"
S = "${WORKDIR}/git"
@@ -29,7 +33,7 @@ do_compile() {
do_install() {
install -d ${D}/${bindir}
- install -m 755 daemons/maap/linux/maap_daemon ${D}/${bindir}
+ install -m 755 daemons/maap/linux/build/maap_daemon ${D}/${bindir}
install -m 755 daemons/mrpd/mrpd daemons/mrpd/mrpctl ${D}/${bindir}
install -m 755 daemons/gptp/linux/build/obj/daemon_cl ${D}/${bindir}
}