aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-03 11:04:40 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-16 15:18:14 +0200
commit536e71760745d77f629cd061c0c75681e4de1d2e (patch)
treec0de4a11368b468333a75979d14c2ed6d58a6af6 /meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
parent753029eb30a27058a981bbd2f0f9137b501c887e (diff)
[COMMUNITY] BSP's should not ship files in /usr/local/
* replace /usr/local with path /usr/share/renesas using: RENESAS_DATADIR = "/usr" - meta-rcar-gen3/include/rcar-gen3-path-common.inc Bug-AGL: SPEC-533 Change-Id: I865ea809c3c59ba136027fc8b99628df20c16275 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb b/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
index fb41431..a83d871 100644
--- a/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
+++ b/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
@@ -20,15 +20,15 @@ do_compile() {
do_install() {
# Create destination folder
- install -d ${D}/usr/local/bin/
+ install -d ${D}${RENESAS_DATADIR}/bin/
# Copy user test program
if [ X${WS} = "X32" ]; then
- install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}/usr/local/bin/vspm_tp32
- install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}/usr/local/bin/fdpm_tp32
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}${RENESAS_DATADIR}/bin/vspm_tp32
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}${RENESAS_DATADIR}/bin/fdpm_tp32
else
- install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}/usr/local/bin/
- install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}/usr/local/bin/
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}${RENESAS_DATADIR}/bin/
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}${RENESAS_DATADIR}/bin/
fi
}
@@ -37,10 +37,10 @@ PACKAGES = "\
${PN}-dbg \
"
FILES_${PN} = " \
- ${@base_conditional('WS', '32', '/usr/local/bin/vspm_tp32 /usr/local/bin/fdpm_tp32', \
- '/usr/local/bin/vspm_tp /usr/local/bin/fdpm_tp', d)}"
+ ${@base_conditional('WS', '32', '${RENESAS_DATADIR}/bin/vspm_tp32 ${RENESAS_DATADIR}/bin/fdpm_tp32', \
+ '${RENESAS_DATADIR}/bin/vspm_tp ${RENESAS_DATADIR}/bin/fdpm_tp', d)}"
FILES_${PN}-dbg = " \
- /usr/local/bin/.debug/*"
+ ${RENESAS_DATADIR}/bin/.debug/*"
RPROVIDES_${PN} += "vspmif-tp-user-module"