aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-03 11:04:40 +0200
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-08-25 08:45:31 +0700
commitf3b86897081316113688a3f42e84fd48b17770b3 (patch)
tree85cf8d2d750a48d8260ce814563288a3d6f26329 /meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
parent006e8f75ad2a6d34b8c32ed1e35052990f2425c3 (diff)
rcar-gen3: Use flexible coding style for Renesas datadir
This commit modifies recipes to use RENESAS_DATADIR variable for /usr/local directory instead of hard coding. This commit comes from AGL patch. Bug-AGL: SPEC-533 Change-Id: I865ea809c3c59ba136027fc8b99628df20c16275 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> (cherry picked from commit 9598336fa2b4a4237255cdd866350eb7c03fdd81)
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb b/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
index fb41431..a83d871 100644
--- a/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
+++ b/meta-rcar-gen3/recipes-multimedia/vspmif-module/vspmif-tp-user-module.bb
@@ -20,15 +20,15 @@ do_compile() {
do_install() {
# Create destination folder
- install -d ${D}/usr/local/bin/
+ install -d ${D}${RENESAS_DATADIR}/bin/
# Copy user test program
if [ X${WS} = "X32" ]; then
- install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}/usr/local/bin/vspm_tp32
- install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}/usr/local/bin/fdpm_tp32
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}${RENESAS_DATADIR}/bin/vspm_tp32
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}${RENESAS_DATADIR}/bin/fdpm_tp32
else
- install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}/usr/local/bin/
- install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}/usr/local/bin/
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/vspm_tp ${D}${RENESAS_DATADIR}/bin/
+ install -m 755 ${S}/${VSPMIF_TP_DIR}/fdpm_tp ${D}${RENESAS_DATADIR}/bin/
fi
}
@@ -37,10 +37,10 @@ PACKAGES = "\
${PN}-dbg \
"
FILES_${PN} = " \
- ${@base_conditional('WS', '32', '/usr/local/bin/vspm_tp32 /usr/local/bin/fdpm_tp32', \
- '/usr/local/bin/vspm_tp /usr/local/bin/fdpm_tp', d)}"
+ ${@base_conditional('WS', '32', '${RENESAS_DATADIR}/bin/vspm_tp32 ${RENESAS_DATADIR}/bin/fdpm_tp32', \
+ '${RENESAS_DATADIR}/bin/vspm_tp ${RENESAS_DATADIR}/bin/fdpm_tp', d)}"
FILES_${PN}-dbg = " \
- /usr/local/bin/.debug/*"
+ ${RENESAS_DATADIR}/bin/.debug/*"
RPROVIDES_${PN} += "vspmif-tp-user-module"