summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2015.04.inc8
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb9
2 files changed, 12 insertions, 5 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2015.04.inc b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2015.04.inc
new file mode 100644
index 0000000..21304be
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2015.04.inc
@@ -0,0 +1,8 @@
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+SECTION = "bootloaders"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+PE = "1"
+
+S = "${WORKDIR}/git"
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
index aff61ae..b8ed7c3 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
@@ -1,14 +1,13 @@
+require recipes-bsp/u-boot/u-boot-common_${PV}.inc
require recipes-bsp/u-boot/u-boot.inc
DEPENDS += "dtc-native"
UBOOT_URL = "git://github.com/renesas-rcar/u-boot.git"
-BRANCH = "v2015.04/rcar-3.5.9"
-
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+BRANCH = "v2015.04/rcar-3.6.0"
SRC_URI = "${UBOOT_URL};branch=${BRANCH}"
-SRCREV = "24add58d915191d901915a6a8cc44faa748fcaa2"
+SRCREV = "eaf09736bb2f1458e19ae0c3176b97ec3aa00219"
PV = "v2015.04+git${SRCPV}"
@@ -19,7 +18,7 @@ UBOOT_SREC_IMAGE ?= "u-boot-elf-${MACHINE}-${PV}-${PR}.srec"
UBOOT_SREC_SYMLINK ?= "u-boot-elf-${MACHINE}.srec"
do_deploy_append() {
- install -m 644 ${S}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
+ install -m 644 ${B}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
cd ${DEPLOYDIR}
rm -f ${UBOOT_SREC} ${UBOOT_SREC_SYMLINK}
ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC_SYMLINK}