aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch44
-rw-r--r--meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend7
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch
new file mode 100644
index 0000000..db61eb2
--- /dev/null
+++ b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch
@@ -0,0 +1,44 @@
+From b2c3e7f58710bb5cc119845d72bc7c4ba5b4cb16 Mon Sep 17 00:00:00 2001
+From: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com>
+Date: Tue, 13 Mar 2018 13:28:52 +0700
+Subject: [PATCH] gl-state-egl: Avoid build failure due to miss macro
+ declaration
+
+This commit avoids the following error:
+
+| ../src/gl-state-egl.cpp: In member function 'bool GLStateEGL::gotValidDisplay()':
+| ../src/gl-state-egl.cpp:420:41: error: 'EGL_PLATFORM_GBM_KHR' was not declared in this scope
+| #define GLMARK2_NATIVE_EGL_DISPLAY_ENUM EGL_PLATFORM_GBM_KHR
+| ^
+| ../src/gl-state-egl.cpp:444:17: note: in expansion of macro 'GLMARK2_NATIVE_EGL_DISPLAY_ENUM'
+| GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
+| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+| ../src/gl-state-egl.cpp:420:41: note: suggested alternative: 'EGL_PLATFORM_GBM_MESA'
+| #define GLMARK2_NATIVE_EGL_DISPLAY_ENUM EGL_PLATFORM_GBM_KHR
+| ^
+| ../src/gl-state-egl.cpp:444:17: note: in expansion of macro 'GLMARK2_NATIVE_EGL_DISPLAY_ENUM'
+| GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
+| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com>
+---
+ src/gl-state-egl.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/gl-state-egl.cpp b/src/gl-state-egl.cpp
+index 6f4f420..0edcdc1 100644
+--- a/src/gl-state-egl.cpp
++++ b/src/gl-state-egl.cpp
+@@ -440,8 +440,7 @@ GLStateEGL::gotValidDisplay()
+ eglGetProcAddress("eglGetPlatformDisplayEXT"));
+
+ if (get_platform_display != nullptr) {
+- egl_display_ = get_platform_display(
+- GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
++ eglGetDisplay(native_display_);
+ }
+
+ if (!egl_display_) {
+--
+2.7.4
+
diff --git a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend
new file mode 100644
index 0000000..4cfc8d8
--- /dev/null
+++ b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append = " \
+ file://0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch \
+"
+
+PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm libgbm"
+PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm libgbm"