aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig9
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb6
3 files changed, 11 insertions, 8 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
index 5609a31..6f31703 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
@@ -2,8 +2,8 @@ require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.0"
-SRCREV = "cdbdfa1452a86607db4d43914f4953ac811d2c56"
+BRANCH = "v4.14/rcar-3.6.1"
+SRCREV = "4a7e26bdbc8d210369eab25765c277200cd910a8"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
index 4f92dc4..94c1631 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
@@ -386,6 +386,7 @@ CONFIG_ARCH_R8A7795=y
CONFIG_ARCH_R8A7796=y
CONFIG_ARCH_R8A77965=y
CONFIG_ARCH_R8A77970=y
+CONFIG_ARCH_R8A77990=y
CONFIG_ARCH_R8A77995=y
CONFIG_ARCH_STRATIX10=y
CONFIG_ARCH_TEGRA=y
@@ -2585,6 +2586,7 @@ CONFIG_PINCTRL_SH_PFC=y
CONFIG_PINCTRL_PFC_R8A7795=y
CONFIG_PINCTRL_PFC_R8A7796=y
CONFIG_PINCTRL_PFC_R8A77965=y
+CONFIG_PINCTRL_PFC_R8A77990=y
CONFIG_PINCTRL_PFC_R8A77995=y
# CONFIG_PINCTRL_SPRD is not set
CONFIG_PINCTRL_SUNXI=y
@@ -2697,8 +2699,7 @@ CONFIG_GPIO_MAX77620=y
# USB GPIO expanders
#
# CONFIG_W1 is not set
-CONFIG_POWER_AVS=y
-# CONFIG_ROCKCHIP_IODOMAIN is not set
+# CONFIG_POWER_AVS is not set
CONFIG_POWER_RESET=y
CONFIG_POWER_RESET_BRCMSTB=y
# CONFIG_POWER_RESET_GPIO is not set
@@ -4932,6 +4933,7 @@ CONFIG_CLK_R8A7795=y
CONFIG_CLK_R8A7796=y
CONFIG_CLK_R8A77965=y
CONFIG_CLK_R8A77970=y
+CONFIG_CLK_R8A77990=y
CONFIG_CLK_R8A77995=y
CONFIG_CLK_RCAR_GEN3_CPG=y
# CONFIG_CLK_RCAR_USB2_CLOCK_SEL is not set
@@ -5024,7 +5026,6 @@ CONFIG_RPMSG=y
# CONFIG_RPMSG_QCOM_GLINK_RPM is not set
# CONFIG_RPMSG_QCOM_GLINK_SMEM is not set
CONFIG_RPMSG_QCOM_SMD=y
-CONFIG_RPMSG_VIRTIO=y
#
# SOC (System On Chip) specific Drivers
@@ -5066,10 +5067,12 @@ CONFIG_SYSC_R8A7795=y
CONFIG_SYSC_R8A7796=y
CONFIG_SYSC_R8A77965=y
CONFIG_SYSC_R8A77970=y
+CONFIG_SYSC_R8A77990=y
CONFIG_SYSC_R8A77995=y
CONFIG_RST_RCAR=y
CONFIG_SYSC_RCAR=y
CONFIG_RCAR_THERMAL_EMS=y
+CONFIG_RCAR_POWER_AVS=y
CONFIG_ROCKCHIP_GRF=y
CONFIG_ROCKCHIP_PM_DOMAINS=y
CONFIG_SOC_SAMSUNG=y
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 31695e0..61f3803 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -4,11 +4,11 @@ require include/avb-control.inc
require recipes-kernel/linux/linux-yocto.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
-COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
+COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.0"
-SRCREV = "cdbdfa1452a86607db4d43914f4953ac811d2c56"
+BRANCH = "v4.14/rcar-3.6.1"
+SRCREV = "4a7e26bdbc8d210369eab25765c277200cd910a8"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"