aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen3/include/uboot-control.inc11
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb8
2 files changed, 17 insertions, 2 deletions
diff --git a/meta-rcar-gen3/include/uboot-control.inc b/meta-rcar-gen3/include/uboot-control.inc
new file mode 100644
index 0000000..859295b
--- /dev/null
+++ b/meta-rcar-gen3/include/uboot-control.inc
@@ -0,0 +1,11 @@
+# This function is to add more U-Boot options to build with H3 (SoC: r8a7795)
+
+def get_uboot_config_opt(d):
+ option = d.getVar('H3_OPTION')
+ if option == "1":
+ d.setVar('UBOOT_CONFIG_OPT',' KCFLAGS+=-DRCAR_DRAM_MAP4_2 KAFLAGS+=-DRCAR_DRAM_MAP4_2')
+ elif option == "2":
+ d.setVar('UBOOT_CONFIG_OPT',' KCFLAGS+=-DRCAR_DRAM_MAP2_2 KAFLAGS+=-DRCAR_DRAM_MAP2_2')
+ else:
+ d.setVar('UBOOT_CONFIG_OPT','')
+ return d.getVar('UBOOT_CONFIG_OPT')
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
index 1594982..c6f9703 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
@@ -1,18 +1,22 @@
require recipes-bsp/u-boot/u-boot-common_${PV}.inc
require recipes-bsp/u-boot/u-boot.inc
+require include/uboot-control.inc
DEPENDS += "dtc-native"
UBOOT_URL = "git://github.com/renesas-rcar/u-boot.git"
-BRANCH = "v2015.04/rcar-3.6.1"
+BRANCH = "v2015.04/rcar-3.6.2"
SRC_URI = "${UBOOT_URL};branch=${BRANCH}"
-SRCREV = "9d718378c4e48d043832f2c2067eb08478c19c53"
+SRCREV = "fb858758470b6ca8e829c9ad455ecac3dbb9774c"
PV = "v2015.04+git${SRCPV}"
EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline"
+# Add u-boot options for H3
+EXTRA_OEMAKE_append_r8a7795 = " ${@get_uboot_config_opt(d)}"
+
UBOOT_SREC ?= "u-boot-elf.srec"
UBOOT_SREC_IMAGE ?= "u-boot-elf-${MACHINE}-${PV}-${PR}.srec"
UBOOT_SREC_SYMLINK ?= "u-boot-elf-${MACHINE}.srec"