aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/docs/sample/patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3-adas/docs/sample/patch')
-rw-r--r--meta-rcar-gen3-adas/docs/sample/patch/0001-meta-linaro-python-wand-fix-BB_NO_NETWORK-build.patch28
-rw-r--r--meta-rcar-gen3-adas/docs/sample/patch/0002-meta-renesas-gstreamer-fix-BB_NO_NETWORK-build.patch92
-rw-r--r--meta-rcar-gen3-adas/docs/sample/patch/0003-poky-bitbake-gitsm-fix-BB_NO_NETWORK-build.patch47
3 files changed, 167 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/docs/sample/patch/0001-meta-linaro-python-wand-fix-BB_NO_NETWORK-build.patch b/meta-rcar-gen3-adas/docs/sample/patch/0001-meta-linaro-python-wand-fix-BB_NO_NETWORK-build.patch
new file mode 100644
index 0000000..9be94b0
--- /dev/null
+++ b/meta-rcar-gen3-adas/docs/sample/patch/0001-meta-linaro-python-wand-fix-BB_NO_NETWORK-build.patch
@@ -0,0 +1,28 @@
+From 749accec83f1b300fc14b5e31fd11c372ca03927 Mon Sep 17 00:00:00 2001
+From: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+Date: Sun, 17 Sep 2017 00:31:15 +0300
+Subject: [PATCH] meta-linaro: python-wand: fix BB_NO_NETWORK build
+
+This fixes python-wand tag in BSP2.23 to build with BB_NO_NETWORK=1
+
+Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+---
+ meta-optee/recipes-devtools/python/python-wand_0.4.3.bb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meta-optee/recipes-devtools/python/python-wand_0.4.3.bb b/meta-optee/recipes-devtools/python/python-wand_0.4.3.bb
+index cc91892..41a6b8f 100644
+--- a/meta-optee/recipes-devtools/python/python-wand_0.4.3.bb
++++ b/meta-optee/recipes-devtools/python/python-wand_0.4.3.bb
+@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=170eafd687d4a2b950819cd5e067e6d5"
+
+ SRCNAME = "wand"
+
+-SRC_URI = "git://github.com/dahlia/wand.git;tag=${PV}"
++SRC_URI = "git://github.com/dahlia/wand.git;tag=81b2ce5ac117cd69e4894780925fab12ff0383b9"
+ S = "${WORKDIR}/git"
+
+ inherit setuptools
+--
+1.9.1
+
diff --git a/meta-rcar-gen3-adas/docs/sample/patch/0002-meta-renesas-gstreamer-fix-BB_NO_NETWORK-build.patch b/meta-rcar-gen3-adas/docs/sample/patch/0002-meta-renesas-gstreamer-fix-BB_NO_NETWORK-build.patch
new file mode 100644
index 0000000..3dcb6be
--- /dev/null
+++ b/meta-rcar-gen3-adas/docs/sample/patch/0002-meta-renesas-gstreamer-fix-BB_NO_NETWORK-build.patch
@@ -0,0 +1,92 @@
+From 4babf852ffee2e08e5fd1c1097bd17c235cd78fa Mon Sep 17 00:00:00 2001
+From: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+Date: Sun, 17 Sep 2017 00:36:21 +0300
+Subject: [PATCH] meta-renesas: gstreamer: fix BB_NO_NETWORK build
+
+Use gitsm for submodule intiializeation. This will enable caching
+submodule gits into downloads.
+Later it is needed for build with BB_NO_NETWORK=1
+
+Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+---
+ .../gstreamer/gstreamer1.0-omx_1.2.0.bbappend | 2 +-
+ .../gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend | 15 +--------------
+ .../gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend | 15 +--------------
+ 3 files changed, 3 insertions(+), 29 deletions(-)
+
+diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
+index 9a30dd9..4606392 100644
+--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
++++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
+@@ -1,5 +1,5 @@
+ SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
+-SRC_URI_append = " git://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.2.0"
++SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.2.0"
+
+ DEPENDS += "omx-user-module mmngrbuf-user-module"
+
+diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
+index 73b5529..b44408c 100644
+--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
++++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
+@@ -1,5 +1,5 @@
+ SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz"
+-SRC_URI_append = " git://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.6.3"
++SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.6.3"
+
+ SRCREV = "e336b2dacf29a155dc8f6896ee0f3a89d87d805e"
+
+@@ -7,19 +7,6 @@ DEPENDS += "weston"
+
+ S = "${WORKDIR}/git"
+
+-# submodule is extracted before do_populate_lic
+-addtask do_init_submodule after do_unpack before do_patch
+-
+-do_init_submodule() {
+- export http_proxy=${http_proxy}
+- export https_proxy=${https_proxy}
+- export HTTP_PROXY=${HTTP_PROXY}
+- export HTTPS_PROXY=${HTTPS_PROXY}
+- cd ${S}
+- git submodule init
+- git submodule update
+-}
+-
+ do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh --noconfigure
+diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
+index 1d353ec..76a3979 100644
+--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
++++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
+@@ -1,5 +1,5 @@
+ SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz"
+-SRC_URI_append = " git://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.6.3"
++SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.6.3"
+
+ SRCREV = "00beed48b36e0b7f2c92199806cc4cb9e0990166"
+
+@@ -12,19 +12,6 @@ EXTRA_OECONF_append = " \
+ --enable-ignore-fps-of-video-standard \
+ "
+
+-# submodule is extracted before do_populate_lic
+-addtask do_init_submodule after do_unpack before do_patch
+-
+-do_init_submodule() {
+- export http_proxy=${http_proxy}
+- export https_proxy=${https_proxy}
+- export HTTP_PROXY=${HTTP_PROXY}
+- export HTTPS_PROXY=${HTTPS_PROXY}
+- cd ${S}
+- git submodule init
+- git submodule update
+-}
+-
+ do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh --noconfigure
+--
+1.9.1
+
diff --git a/meta-rcar-gen3-adas/docs/sample/patch/0003-poky-bitbake-gitsm-fix-BB_NO_NETWORK-build.patch b/meta-rcar-gen3-adas/docs/sample/patch/0003-poky-bitbake-gitsm-fix-BB_NO_NETWORK-build.patch
new file mode 100644
index 0000000..4160351
--- /dev/null
+++ b/meta-rcar-gen3-adas/docs/sample/patch/0003-poky-bitbake-gitsm-fix-BB_NO_NETWORK-build.patch
@@ -0,0 +1,47 @@
+From e0eb46a08a0bdd278800f75c0004e33af2376374 Mon Sep 17 00:00:00 2001
+From: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+Date: Sun, 17 Sep 2017 00:39:12 +0300
+Subject: [PATCH] poky: bitbake: gitsm: fix BB_NO_NETWORK build
+
+This allows to fetch submodules from download cache.
+
+Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de>
+Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
+---
+ bitbake/lib/bb/fetch2/gitsm.py | 15 +++++++++++++--
+ 1 file changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/bitbake/lib/bb/fetch2/gitsm.py b/bitbake/lib/bb/fetch2/gitsm.py
+index 752f1d3..cb417a3 100644
+--- a/bitbake/lib/bb/fetch2/gitsm.py
++++ b/bitbake/lib/bb/fetch2/gitsm.py
+@@ -109,7 +109,7 @@ class GitSM(Git):
+ runfetchcmd("sed " + gitdir + "/config -i -e 's/bare.*=.*true/bare = false/'", d)
+ os.chdir(tmpclonedir)
+ runfetchcmd(ud.basecmd + " reset --hard", d)
+- runfetchcmd(ud.basecmd + " checkout " + ud.revisions[ud.names[0]], d)
++ runfetchcmd(ud.basecmd + " checkout -f " + ud.revisions[ud.names[0]], d)
+ runfetchcmd(ud.basecmd + " submodule update --init --recursive", d)
+ self._set_relative_paths(tmpclonedir)
+ runfetchcmd("sed " + gitdir + "/config -i -e 's/bare.*=.*false/bare = true/'", d)
+@@ -130,5 +130,16 @@ class GitSM(Git):
+ os.chdir(ud.destdir)
+ submodules = self.uses_submodules(ud, d)
+ if submodules:
++ # Copy also submodule trees from download cache instead of
++ # downloading again from the upstream repository.
++ # For some reason git does not clone them.
++ clone_modules = os.path.join(ud.clonedir, "modules")
++ if os.path.exists(clone_modules):
++ dest_modules = os.path.join(ud.destdir, ".git")
++ runfetchcmd("cp -a " + clone_modules + " " + dest_modules, d)
++
+ runfetchcmd(ud.basecmd + " checkout " + ud.revisions[ud.names[0]], d)
+- runfetchcmd(ud.basecmd + " submodule update --init --recursive", d)
++ if d.getVar("BB_NO_NETWORK", True) == "1":
++ runfetchcmd(ud.basecmd + " submodule update --no-fetch --init --recursive", d)
++ else:
++ runfetchcmd(ud.basecmd + " submodule update --init --recursive", d)
+--
+1.9.1
+