summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb')
-rw-r--r--meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
new file mode 100644
index 0000000..9c27f81
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec"
+HOMEPAGE = "https://github.com/jbeder/yaml-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
+
+DEPENDS = "boost"
+
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/jbeder/yaml-cpp.git"
+SRCREV = "bedb28fdb4fd52d97e02f6cb946cae631037089e"
+
+# pkgconfig is enough
+do_install_append() {
+ rm -r ${D}${libdir}/cmake
+}
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+inherit cmake \ No newline at end of file