summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-devtools/yaml-cpp')
-rw-r--r--meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_0.5.3.bb19
-rw-r--r--meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb23
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_0.5.3.bb b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_0.5.3.bb
new file mode 100644
index 0000000..0a05595
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_0.5.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec"
+HOMEPAGE = "https://github.com/jbeder/yaml-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
+
+DEPENDS = "boost"
+
+PR = "r0"
+
+S = "${WORKDIR}/yaml-cpp-release-${PV}"
+
+SRC_URI = "https://github.com/jbeder/yaml-cpp/archive/release-${PV}.tar.gz"
+SRC_URI[md5sum] = "64200ca0bf5e0af065804d8d3e8f6d42"
+SRC_URI[sha256sum] = "ac50a27a201d16dc69a881b80ad39a7be66c4d755eda1f76c3a68781b922af8f"
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+inherit cmake
diff --git a/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
new file mode 100644
index 0000000..9c27f81
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec"
+HOMEPAGE = "https://github.com/jbeder/yaml-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
+
+DEPENDS = "boost"
+
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/jbeder/yaml-cpp.git"
+SRCREV = "bedb28fdb4fd52d97e02f6cb946cae631037089e"
+
+# pkgconfig is enough
+do_install_append() {
+ rm -r ${D}${libdir}/cmake
+}
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+inherit cmake \ No newline at end of file