aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch')
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch353
1 files changed, 0 insertions, 353 deletions
diff --git a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch
deleted file mode 100644
index e067e58..0000000
--- a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-arm64-dts-r8a7796-salvator-x-view-add-ADAS-board.patch
+++ /dev/null
@@ -1,353 +0,0 @@
-From 782e569e0b0e252b03fdaecae2e6f7c3267a4bcd Mon Sep 17 00:00:00 2001
-From: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
-Date: Mon, 17 Apr 2017 19:12:29 +0300
-Subject: [PATCH] arm64: dts: r8a7796-salvator-x-view: add ADAS board
-
-Salvator-X.View board on R8A7796 SoC
-
-Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
----
- arch/arm64/boot/dts/renesas/Makefile | 1 +
- .../boot/dts/renesas/r8a7796-salvator-x-view.dts | 318 +++++++++++++++++++++
- 2 files changed, 319 insertions(+)
- create mode 100644 arch/arm64/boot/dts/renesas/r8a7796-salvator-x-view.dts
-
-diff --git a/arch/arm64/boot/dts/renesas/Makefile b/arch/arm64/boot/dts/renesas/Makefile
-index 49ddbd1..52bbef2 100644
---- a/arch/arm64/boot/dts/renesas/Makefile
-+++ b/arch/arm64/boot/dts/renesas/Makefile
-@@ -8,6 +8,7 @@ dtb-$(CONFIG_ARCH_R8A7796) += r8a7796-salvator-xs.dtb
- dtb-$(CONFIG_ARCH_R8A7795) += r8a7795-es1-h3ulcb-view.dtb
- dtb-$(CONFIG_ARCH_R8A7795) += r8a7795-es1-h3ulcb-had-alfa.dtb r8a7795-es1-h3ulcb-had-beta.dtb
- dtb-$(CONFIG_ARCH_R8A7795) += r8a7795-es1-h3ulcb-kf.dtb r8a7795-es1-h3ulcb-kf-v1.dtb
-+dtb-$(CONFIG_ARCH_R8A7796) += r8a7796-salvator-x-view.dtb
-
- always := $(dtb-y)
- clean-files := *.dtb
-diff --git a/arch/arm64/boot/dts/renesas/r8a7796-salvator-x-view.dts b/arch/arm64/boot/dts/renesas/r8a7796-salvator-x-view.dts
-new file mode 100644
-index 0000000..cc6866c
---- /dev/null
-+++ b/arch/arm64/boot/dts/renesas/r8a7796-salvator-x-view.dts
-@@ -0,0 +1,318 @@
-+/*
-+ * Device Tree Source for the Salvator-X.View board
-+ *
-+ * Copyright (C) 2016-2017 Renesas Electronics Corp.
-+ * Copyright (C) 2016-2017 Cogent Embedded, Inc
-+ *
-+ * This file is licensed under the terms of the GNU General Public License
-+ * version 2. This program is licensed "as is" without any warranty of any
-+ * kind, whether express or implied.
-+ */
-+
-+#include "r8a7796-salvator-x.dts"
-+
-+/ {
-+ model = "Renesas Salvator-X.View board based on r8a7796";
-+};
-+
-+&pfc {
-+ can0_pins: can0 {
-+ groups = "can0_data_a";
-+ function = "can0";
-+ };
-+
-+ can1_pins: can1 {
-+ groups = "can1_data";
-+ function = "can1";
-+ };
-+};
-+
-+&i2c4 {
-+ /delete-node/hdmi-in@34;
-+ /delete-node/composite-in@70;
-+
-+ ov106xx@0 {
-+ compatible = "ovti,ov106xx";
-+ reg = <0x60>;
-+
-+ port@0 {
-+ ov106xx_in0: endpoint {
-+ clock-lanes = <0>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&vin0ep0>;
-+ };
-+ };
-+ port@1 {
-+ ov106xx_max9286_des0ep0: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep0>;
-+ };
-+ };
-+ };
-+
-+ ov106xx@1 {
-+ compatible = "ovti,ov106xx";
-+ reg = <0x61>;
-+
-+ port@0 {
-+ ov106xx_in1: endpoint {
-+ clock-lanes = <0>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&vin1ep0>;
-+ };
-+ };
-+ port@1 {
-+ ov106xx_max9286_des0ep1: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep1>;
-+ };
-+ };
-+ };
-+
-+ ov106xx@2 {
-+ compatible = "ovti,ov106xx";
-+ reg = <0x62>;
-+
-+ port@0 {
-+ ov106xx_in2: endpoint {
-+ clock-lanes = <0>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&vin2ep0>;
-+ };
-+ };
-+ port@1 {
-+ ov106xx_max9286_des0ep2: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep2>;
-+ };
-+ };
-+ };
-+
-+ ov106xx@3 {
-+ compatible = "ovti,ov106xx";
-+ reg = <0x63>;
-+
-+ port@0 {
-+ ov106xx_in3: endpoint {
-+ clock-lanes = <0>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&vin3ep0>;
-+ };
-+ };
-+ port@1 {
-+ ov106xx_des0ep3: endpoint {
-+ remote-endpoint = <&max9286_des0ep3>;
-+ };
-+ };
-+ };
-+
-+ max9286-max9271@0 {
-+ compatible = "maxim,max9286-max9271";
-+ reg = <0x4c>;
-+ gpios = <&gpio6 30 GPIO_ACTIVE_LOW>;
-+ maxim,sensor_delay = <0>;
-+ maxim,links = <4>;
-+ maxim,lanes = <4>;
-+ maxim,resetb-gpio = <1>;
-+ maxim,fsync-mode = "automatic";
-+ maxim,timeout = <100>;
-+ maxim,i2c-quirk = <0x6c>;
-+
-+ port@0 {
-+ max9286_des0ep0: endpoint@0 {
-+ max9271-addr = <0x50>;
-+ dvp-order = <1>;
-+ remote-endpoint = <&ov106xx_in0>;
-+ };
-+ max9286_des0ep1: endpoint@1 {
-+ max9271-addr = <0x51>;
-+ dvp-order = <1>;
-+ remote-endpoint = <&ov106xx_in1>;
-+ };
-+ max9286_des0ep2: endpoint@2 {
-+ max9271-addr = <0x52>;
-+ dvp-order = <1>;
-+ remote-endpoint = <&ov106xx_in2>;
-+ };
-+ max9286_des0ep3: endpoint@3 {
-+ max9271-addr = <0x53>;
-+ dvp-order = <1>;
-+ remote-endpoint = <&ov106xx_in3>;
-+ };
-+ };
-+ port@1 {
-+ max9286_csi0ep0: endpoint {
-+ csi-rate = <700>;
-+ remote-endpoint = <&csi2_40_ep>;
-+ };
-+ };
-+ };
-+};
-+
-+&vin0 {
-+ ports {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ port@0 {
-+ vin0ep0: endpoint {
-+ csi,select = "csi40";
-+ virtual,channel = <0>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&ov106xx_in0>;
-+ };
-+ };
-+ port@1 {
-+ csi0ep0: endpoint {
-+ remote-endpoint = <&csi2_40_ep>;
-+ };
-+ };
-+ port@2 {
-+ vin0_max9286_des0ep0: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep0>;
-+ };
-+ };
-+ };
-+};
-+
-+&vin1 {
-+ ports {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ port@0 {
-+ vin1ep0: endpoint {
-+ csi,select = "csi40";
-+ virtual,channel = <1>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&ov106xx_in1>;
-+ };
-+ };
-+ port@1 {
-+ csi0ep1: endpoint {
-+ remote-endpoint = <&csi2_40_ep>;
-+ };
-+ };
-+ port@2 {
-+ vin1_max9286_des0ep1: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep1>;
-+ };
-+ };
-+ };
-+};
-+
-+&vin2 {
-+ ports {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ port@0 {
-+ vin2ep0: endpoint {
-+ csi,select = "csi40";
-+ virtual,channel = <2>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&ov106xx_in2>;
-+ };
-+ };
-+ port@1 {
-+ csi0ep2: endpoint {
-+ remote-endpoint = <&csi2_40_ep>;
-+ };
-+ };
-+ port@2 {
-+ vin2_max9286_des0ep2: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep2>;
-+ };
-+ };
-+ };
-+};
-+
-+&vin3 {
-+ ports {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ port@0 {
-+ vin3ep0: endpoint {
-+ csi,select = "csi40";
-+ virtual,channel = <3>;
-+ data-lanes = <1 2 3 4>;
-+ remote-endpoint = <&ov106xx_in3>;
-+ };
-+ };
-+ port@1 {
-+ csi0ep3: endpoint {
-+ remote-endpoint = <&csi2_40_ep>;
-+ };
-+ };
-+ port@2 {
-+ vin3_max9286_des0ep3: endpoint@0 {
-+ remote-endpoint = <&max9286_des0ep3>;
-+ };
-+ };
-+ };
-+};
-+
-+&vin4 {
-+ status = "disabled";
-+};
-+
-+&vin5 {
-+ status = "disabled";
-+};
-+
-+&vin6 {
-+ status = "disabled";
-+};
-+
-+&vin7 {
-+ status = "disabled";
-+};
-+
-+&csi2_20 {
-+ status = "disabled";
-+ /delete-node/ports;
-+};
-+
-+&csi2_40 {
-+ /delete-node/ports;
-+
-+ virtual,channel {
-+ csi2_vc0 {
-+ data,type = "ycbcr422";
-+ receive,vc = <0>;
-+ };
-+ csi2_vc1 {
-+ data,type = "ycbcr422";
-+ receive,vc = <1>;
-+ };
-+ csi2_vc2 {
-+ data,type = "ycbcr422";
-+ receive,vc = <2>;
-+ };
-+ csi2_vc3 {
-+ data,type = "ycbcr422";
-+ receive,vc = <3>;
-+ };
-+ };
-+
-+ port {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ csi2_40_ep: endpoint {
-+ clock-lanes = <0>;
-+ data-lanes = <1 2 3 4>;
-+ csi-rate = <300>;
-+ };
-+ };
-+};
-+
-+&can0 {
-+ pinctrl-0 = <&can0_pins>;
-+ pinctrl-names = "default";
-+ status = "okay";
-+};
-+
-+&can1 {
-+ pinctrl-0 = <&can1_pins>;
-+ pinctrl-names = "default";
-+ status = "okay";
-+};
---
-1.9.1
-