aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend b/meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend
new file mode 100644
index 0000000..66183b1
--- /dev/null
+++ b/meta-rcar-gen3/recipes-core/dbus/dbus_1.10.20.bbappend
@@ -0,0 +1,12 @@
+# WORKAROUND for memory leak issue when restart weston
+
+# Make sure the WORKAROUND only effect with GFX and MMP config
+ENABLE_FIX = "${@'1' if 'gsx' in '${MACHINE_FEATURES}' else '0'}"
+
+# Modify dbus.service to make dbus restarts depend on weston
+do_install_prepend() {
+ if [ "X${ENABLE_FIX}" = "X1" ]; then
+ sed -e "/Requires=dbus.socket/a PartOf=weston.service" \
+ -i ${B}/bus/dbus.service
+ fi
+}