aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb')
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb
new file mode 100644
index 0000000..f4c6129
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-module-egl-headers.bb
@@ -0,0 +1,36 @@
+require include/gles-control.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/gles-user-module:"
+
+DESCRIPTION = "PowerVR GPU user EGL header files"
+LICENSE = "CLOSED"
+
+PN = "gles-module-egl-headers"
+PR = "r0"
+
+COMPATIBLE_MACHINE = "(r8a7795|r8a7796)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+S = "${WORKDIR}/rogue"
+
+SRC_URI_r8a7795 = "file://r8a7795_linux_gsx_binaries_gles3.tar.bz2"
+SRC_URI_r8a7796 = "file://r8a7796_linux_gsx_binaries_gles3.tar.bz2"
+SRC_URI_append = " \
+ file://0001-EGL-eglext.h-Include-eglmesaext.h-to-avoid-compile-error.patch \
+"
+
+do_populate_lic[noexec] = "1"
+do_compile[noexec] = "1"
+
+# The headers need headers from virtual/mesa.
+do_populate_sysroot[depends] += "virtual/mesa:do_populate_sysroot"
+
+do_install() {
+ # Install header files
+ install -d ${D}/${includedir}/EGL
+ install -m 644 ${S}/${includedir}/EGL/*.h ${D}/${includedir}/EGL/
+ install -d ${D}/${includedir}/KHR
+ install -m 644 ${S}/${includedir}/KHR/khrplatform.h ${D}/${includedir}/KHR/khrplatform.h
+}
+
+RDEPENDS_${PN}-dev = ""