aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
index 66dedfe..2047457 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
@@ -28,18 +28,31 @@ PACKAGECONFIG_append = " \
PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"
do_install_append() {
+ install -d ${D}/${sysconfdir}/xdg/weston
if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
# install weston.ini as sample settings of v4l2-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
if [ "${MACHINE}" = "m3ulcb" -o "${MACHINE}" = "h3ulcb" ] ; then
sed -i 's|media1|media0|g' ${WORKDIR}/weston_v4l2.ini
fi
install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
else
# install weston.ini as sample settings of gl-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
fi
+
+ # Checking for ivi-shell configuration
+ # If ivi-shell is enable, we will add its configs to weston.ini
+ if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
+ sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
+ ${D}/${sysconfdir}/xdg/weston/weston.ini
+ sed -e '$a\\' \
+ -e '$a\[ivi-shell]' \
+ -e '$a\ivi-module=ivi-controller.so' \
+ -e '$a\ivi-input-module=ivi-input-controller.so' \
+ -e '$a\transition-duration=300' \
+ -e '$a\cursor-theme=default' \
+ -i ${D}/${sysconfdir}/xdg/weston/weston.ini
+ fi
}
FILES_${PN}_append = " \