aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb29
1 files changed, 11 insertions, 18 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 56edb1f..addda0a 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -9,13 +9,14 @@ require include/adsp-control.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
-RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14.70-ltsi-rc1/rcar-3.8.0"
-SRCREV = "52f8a317698424fe3a4ba7f88d2b87fc6bf6591d"
+RENESAS_BSP_URL = " \
+ git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
+BRANCH = "v4.14.75-ltsi/rcar-3.9.2"
+SRCREV = "a5266d298124874c2c06b8b13d073f6ecc2ee355"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"
-LINUX_VERSION ?= "4.14.70"
+LINUX_VERSION ?= "4.14.75"
PV = "${LINUX_VERSION}+git${SRCPV}"
PR = "r1"
@@ -40,22 +41,14 @@ SRC_URI_append = " \
${@base_conditional("USE_CAS", "1", " file://capacity_aware_migration_strategy.cfg", "",d)} \
"
-# Device tree patches
-SRC_URI_append = " \
- file://0001-arm64-dts-salvator-common-Rcar-Sound.patch \
- file://0002-arm64-dts-r8a7796-salvator-xs-Remove-Sound-Card.patch \
- file://0003-arm64-dts-r8a7795-salvator-x-Remove-Sound-Card.patch \
- file://0004-arm64-dts-r8a7795-salvator-xs-Remove-Sound-Card.patch \
- file://0005-arm64-dts-r8a7795-es1-salvator-x-Remove-Sound-Card.patch \
- file://0006-arm64-dts-r8a7796-salvator-x-Remove-Sound-Card.patch \
-"
-
# Add ADSP ALSA driver
SUPPORT_ADSP_ASOC = " \
- file://0001-Add-build-for-ADSP-sound-driver.patch \
- file://0002-Add-document-file-for-ADSP-sound-driver.patch \
- file://0003-Add-ADSP-sound-driver-source.patch \
- file://0004-Update-device-tree-for-ADSP-sound-driver.patch \
+ file://0001-ADSP-add-document-for-compatible-string-renesas-rcar.patch \
+ file://0002-ADSP-add-ADSP-sound-driver-source.patch \
+ file://0003-ADSP-add-build-for-ADSP-sound-driver.patch \
+ file://0004-ADSP-integrate-ADSP-sound-for-H3-M3-M3N-board.patch \
+ file://0005-ADSP-integrate-ADSP-sound-for-E3-board.patch \
+ file://0006-ADSP-remove-HDMI-support-from-rcar-sound.patch \
file://adsp.cfg \
"