aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig19
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb4
3 files changed, 22 insertions, 5 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
index 043ba21..7458312 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
@@ -3,8 +3,8 @@ require include/iccom-control.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.7.0"
-SRCREV = "118adc53e8e9806d76f40859ba96290f289f8839"
+BRANCH = "v4.14/rcar-3.7.3"
+SRCREV = "c5090444b63749f899a39c7d39fbbd65e614eeba"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
index 102f46b..20d4ef5 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
@@ -2910,6 +2910,7 @@ CONFIG_THERMAL_DEFAULT_GOV_POWER_ALLOCATOR=y
CONFIG_THERMAL_GOV_POWER_ALLOCATOR=y
CONFIG_CPU_THERMAL=y
# CONFIG_CLOCK_THERMAL is not set
+# CONFIG_DEVFREQ_THERMAL is not set
CONFIG_THERMAL_EMULATION=y
CONFIG_HISI_THERMAL=y
# CONFIG_MAX77620_THERMAL is not set
@@ -5090,7 +5091,23 @@ CONFIG_SOC_TEGRA_PMC_TEGRA186=y
CONFIG_SOC_TEGRA_POWERGATE_BPMP=y
# CONFIG_SOC_TI is not set
# CONFIG_SOC_ZTE is not set
-# CONFIG_PM_DEVFREQ is not set
+CONFIG_PM_DEVFREQ=y
+
+#
+# DEVFREQ Governors
+#
+CONFIG_DEVFREQ_GOV_SIMPLE_ONDEMAND=y
+CONFIG_DEVFREQ_GOV_PERFORMANCE=y
+CONFIG_DEVFREQ_GOV_POWERSAVE=y
+CONFIG_DEVFREQ_GOV_USERSPACE=y
+CONFIG_DEVFREQ_GOV_PASSIVE=y
+
+#
+# DEVFREQ Drivers
+#
+# CONFIG_ARM_EXYNOS_BUS_DEVFREQ is not set
+# CONFIG_ARM_RK3399_DMC_DEVFREQ is not set
+# CONFIG_PM_DEVFREQ_EVENT is not set
CONFIG_EXTCON=y
#
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 6f88d52..2cc658d 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -9,8 +9,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.7.0"
-SRCREV = "118adc53e8e9806d76f40859ba96290f289f8839"
+BRANCH = "v4.14/rcar-3.7.3"
+SRCREV = "c5090444b63749f899a39c7d39fbbd65e614eeba"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"