aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-11-02 12:04:38 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-04 10:45:44 +0000
commit8d4bf9b524bb6fd00f7e6c3e10bc8f8866fabe09 (patch)
tree46fc38afb8d1bdc0b1dfb3605363fbb377b51464
parent21d40b2e0dc344f6b89c2a71296a4dd2a29a2a4e (diff)
uEnv.txt for booting into OSTree on Porter
Bug-AGL: SPEC-307 Change-Id: I10030197b1cba8f1b0018b8454d6d61a088da706 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
-rw-r--r--meta-rcar-gen2/recipes-bsp/bootfiles/files/uEnv-ota.txt18
-rw-r--r--meta-rcar-gen2/recipes-bsp/bootfiles/porter-bootfiles.bb25
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-bsp/bootfiles/files/uEnv-ota.txt b/meta-rcar-gen2/recipes-bsp/bootfiles/files/uEnv-ota.txt
new file mode 100644
index 0000000..9def764
--- /dev/null
+++ b/meta-rcar-gen2/recipes-bsp/bootfiles/files/uEnv-ota.txt
@@ -0,0 +1,18 @@
+bootkaddr=0x40007fc0
+bootiaddr=0x50000000
+
+bootargs_console=console=ttySC6,38400 ignore_loglevel
+bootargs_video=vmalloc=384M video=HDMI-A-1:1024x768-32@60
+bootargs_extra=rw rootfstype=ext4 rootwait rootdelay=2
+
+bootargs_root=ostree_root=/dev/mmcblk0p2 root=/dev/ram0 ramdisk_size=16384
+
+bootmmc=1:2
+
+booteload_sd=ext4load mmc ${bootmmc} ${bootkaddr} boot/loader/uEnv.txt; env import -t ${bootkaddr} ${filesize}
+
+bootkload_sd=ext4load mmc ${bootmmc} ${bootkaddr} boot/${kernel_image}
+bootiload_sd=ext4load mmc ${bootmmc} ${bootiaddr} boot/${ramdisk_image}
+
+bootcmd=run booteload_sd; setenv bootargs ${bootargs} ${bootargs_console} ${bootargs_video} ${bootargs_root} ${bootargs_extra}; run bootkload_sd; run bootiload_sd; bootm ${bootkaddr} ${bootiaddr}
+
diff --git a/meta-rcar-gen2/recipes-bsp/bootfiles/porter-bootfiles.bb b/meta-rcar-gen2/recipes-bsp/bootfiles/porter-bootfiles.bb
new file mode 100644
index 0000000..2c14a88
--- /dev/null
+++ b/meta-rcar-gen2/recipes-bsp/bootfiles/porter-bootfiles.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Boot files (bootscripts etc.) for Renesas Porter board"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit deploy
+
+COMPATIBLE_MACHINE = "porter"
+
+S = "${WORKDIR}"
+
+SRC_URI_append_sota = "file://uEnv-ota.txt"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+}
+
+do_deploy_append_sota() {
+ install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+