aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-01-18 10:56:49 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-18 10:48:21 +0000
commit94f977531535036e22684ca78dd93d8360d876a2 (patch)
tree5f6662e62d800f223d2b8f51e8877b569d62b95b
parent35289ad4e94bbabf1dfa88e71d5d8bd05964aaa4 (diff)
rcar-gen2: linux-renesas: Fix gst-record plug-in critical logs
Fix gst-record plugin log which filled systemd journal. Change-Id: I2a360ac40b90b835aed124082c214fca05f65120 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston/0004-Fix-GST-error-complainings.patch33
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston_1.9.0.bbappend1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston/0004-Fix-GST-error-complainings.patch b/meta-rcar-gen2/recipes-graphics/wayland/weston/0004-Fix-GST-error-complainings.patch
new file mode 100644
index 0000000..40f2e53
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston/0004-Fix-GST-error-complainings.patch
@@ -0,0 +1,33 @@
+From 1f0c74cb16056d4338188f5de4a9bcf1e1fc79a0 Mon Sep 17 00:00:00 2001
+From: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+Date: Tue, 17 Jan 2017 19:48:01 +0300
+Subject: [PATCH] Fix GST error complainings
+
+GStreamer- CRITICAL **: gst_segment_to_running_time: assertion 'segment->format == format' failed
+
+Signed-off-by: Grigory Kletsko <grigory.kletsko@cogentembedded.com>
+Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+---
+ src/gst-recorder.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/gst-recorder.c b/src/gst-recorder.c
+index c84d410..91ba0c7 100644
+--- a/src/gst-recorder.c
++++ b/src/gst-recorder.c
+@@ -1021,6 +1021,12 @@ gst_recorder_create(struct gst_recorder_settings *settings)
+ "framerate", GST_TYPE_FRACTION, 0, DEFAULT_FPS,
+ NULL), NULL);
+
++ g_object_set (G_OBJECT (r->appsrc),
++ "stream-type", 0, /* GST_APP_STREAM_TYPE_STREAM */
++ "format", GST_FORMAT_TIME,
++ "is-live", TRUE,
++ NULL);
++
+ r->appsrc_pad = gst_element_get_static_pad(GST_ELEMENT_CAST(r->appsrc), "src");
+ if (!r->appsrc_pad)
+ weston_log("Failed to get src0 pad of appsrc\n");
+--
+2.9.2
+
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston_1.9.0.bbappend b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.9.0.bbappend
index 33efb49..533be7e 100644
--- a/meta-rcar-gen2/recipes-graphics/wayland/weston_1.9.0.bbappend
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.9.0.bbappend
@@ -7,5 +7,6 @@ SRC_URI_append = " \
file://0001-Add-virtual-output-support.patch \
file://0002-Get-DMA-fd-on-bo.patch \
file://0003-Add-gst-recorder-for-h264-output-streaming.patch \
+ file://0004-Fix-GST-error-complainings.patch \
file://weston.service \
"