summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2016-02-22 15:11:05 +0000
committerStephen Lawrence <stephen.lawrence@renesas.com>2016-02-22 15:49:14 +0000
commit6f2f97411201815baadb8a0b43837a2035898a9d (patch)
treea9bfafeaf8a607c2010868f850b265d5e68f940a
parent1f292799192d0386fa022423fc872a90aae155b0 (diff)
gstreamer: Fix runtime CMA error
The gstreamer bad wayland sink plugin is dependent on wayland-kms. Make this explicit by adding appropriate DEPENDS/RDEPENDS. Without it the wayland sink plugin can be built with the wrong configuration depending on build order. Incorrectly built the plugin can lead to gst-launch to report an runtime error stating there is insufficient CMA memory.
-rw-r--r--meta-rcar-gen2/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bbappend b/meta-rcar-gen2/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bbappend
index a881d76..83adc79 100644
--- a/meta-rcar-gen2/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bbappend
+++ b/meta-rcar-gen2/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bbappend
@@ -18,6 +18,8 @@ do_configure_prepend() {
# for wayland
PACKAGECONFIG_remove_rcar-gen2 = "${@'orc' if '1' in '${USE_GLES_WAYLAND}' else ''}"
PACKAGECONFIG_append_rcar-gen2 = " faad ${@base_contains('USE_GLES_WAYLAND', '1', 'wayland', '', d)}"
+DEPENDS += "wayland-kms"
+RDEPENDS_${PN} = "libwayland-egl"
# for lcb
DEPENDS_append_silk = " ${@base_conditional('USE_MULTIMEDIA', '1', 'faac', '', d)}"