aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-02-08 17:35:36 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-02-08 17:35:36 +0000
commit45126ad7016c2981a1d9f9f343c157517560b2e2 (patch)
tree8e4a411b3631b840dca5c94231d235a70680ddba
parentd2cf62fcf5dfb535d7527fbc646b6b115e8d8121 (diff)
r-car m2: add a "libGLESv2.so.2" symbolic link for software
Some popular software, including Chromium/QtWebEngine, look for a library named "libGLESv2.so.2" on the filesystem to initialize their OpenGL ES backend : https://github.com/qtproject/qtwebengine/blob/dev/src/core/ surface_factory_qt.cpp#L83 but the proprietary userspace driver is named "libGLESv2.so" instead. Let us create a symbolic link which will satisfy this requirement (we do not rename the binary and make "libGLESv2.so" a symbolic link, because this would trigger a Yocto QA warning and prevent building). Change-Id: Iea901694e90cfd4a786087507cfc77302c9d3b8a Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Author: Yannick Gicquel <yannick.gicquel@iot.bzh> Author: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
index b67b26a..f9f8864 100644
--- a/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
@@ -54,6 +54,9 @@ do_install() {
cp -r ${S}/etc ${D}
cp -r ${S}/usr ${D}
+ # Create a symbolic link for compatibility with various software
+ ln -s ${D}/usr/lib/libGLESv2.so ${D}/usr/lib/libGLESv2.so.2
+
if [ "${USE_WAYLAND}" = "1" ]; then
# Rename libEGL.so
mv ${D}/usr/lib/libEGL.so ${D}/usr/lib/libEGL-pvr.so