summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-27 09:34:34 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-01-27 16:17:17 +0000
commit047d1f920d892edf807156f3dbbc5184e90734aa (patch)
treef7ac058cd7e7ca93bc3263e7166afba4b64bdf77
parent6cc9f412ce7f6f0b6204cbbca600d3fe550c4159 (diff)
r-car m2: add EGL driver EGL_NO_DISPLAY workaroud
Weston 1.8.0 uses a new method of detection for client EGL extensions, which is incompatible with the driver provided by meta-renesas. We revert back to the old behavior as it is not strictly necessary for rendering. This allows Weston 1.8.0 to start in DRM mode on Porter/Koelsch with latest AGL base. Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Change-Id: I0658b3beff96c7f173dbb4f85e8f18d3fce768c1
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch27
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend8
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch b/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch
new file mode 100644
index 0000000..3133d2f
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch
@@ -0,0 +1,27 @@
+--- a/src/gl-renderer.c 2016-01-27 08:49:43.328882567 +0000
++++ b/src/gl-renderer.c 2016-01-27 08:56:31.807915324 +0000
+@@ -2127,7 +2127,11 @@
+ {
+ const char *extensions;
+
++#ifndef EGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT
+ extensions = eglQueryString(EGL_NO_DISPLAY, EGL_EXTENSIONS);
++#else
++ extensions = NULL;
++#endif
+ if (!extensions) {
+ weston_log("Retrieving EGL client extension string failed.\n");
+ return;
+@@ -2246,8 +2250,12 @@
+ char s[64];
+
+ if (!extensions) {
++#ifndef EGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT
+ extensions = (const char *) eglQueryString(
+ EGL_NO_DISPLAY, EGL_EXTENSIONS);
++#else
++ extensions = NULL;
++#endif
+
+ if (!extensions)
+ return 0;
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend
new file mode 100644
index 0000000..383c844
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# EGL driver does not support the EGL_NO_DISPLAY query parameter
+SRC_URI += " \
+ file://weston-workaround-for-egl-no-display.patch \
+ "
+
+CPPFLAGS_append = " -DEGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT=1"