summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-01-18 15:07:23 +0100
committerYannick Gicquel <yannick.gicquel@iot.bzh>2016-01-18 15:07:23 +0100
commit3e8aefb1dbb23d6f1da7ea881e7ba977b9f0fba3 (patch)
tree1c8005afcb8e23d3666380b708821cfbc80836f6
parent430420f83944cb0e39ef22d1e6570edb98b11622 (diff)
gles-module: handle kernel build path in work-shared
Since 46cdaf1c7b in poky (v1.8), kernel source and build artefact are in two separated directories. This patch prepares to use STAGING_KERNEL_BUILDDIR as it is used in KBUILD_OUTPUT from modules-base.bbclass It also set this variable to keep same state as before for poky < 1.8 Change-Id: Ie27593407a85d88da28b8a91c3ea69378bb91a63 Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb b/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
index 7ed44a2..5b47340 100644
--- a/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
+++ b/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
@@ -46,7 +46,8 @@ export BUILDDIR = "${STAGING_INCDIR}/.."
export LIBSHARED = "${STAGING_LIBDIR}"
export KERNELSRC = "${STAGING_KERNEL_DIR}"
export CROSS_COMPILE = "${TARGET_PREFIX}"
-export KERNELDIR = "${STAGING_KERNEL_DIR}"
+STAGING_KERNEL_BUILDDIR ?= "${STAGING_KERNEL_DIR}"
+export KERNELDIR = "${STAGING_KERNEL_BUILDDIR}"
export LDFLAGS=""
export CP = "cp"