summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-01-08 16:19:40 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-01-13 15:47:56 +0000
commit9d986e432921614b6de12f3163f142dcb418a07d (patch)
treeb28c576c4c7e3aa9dccd7e8fc1cf42de680d6dad
parentbb013ecc7450151db021c58614d9fc06b401c3b0 (diff)
u-boot: fixup build with gcc 5
Change-Id: I88cbad396f0757246e83bbebfe0b4ff2841a51b6 Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-fixup-build-with-gcc5.patch86
-rw-r--r--meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-inline-use-the-gcc-inline-version-instead-of-the-c99.patch37
-rw-r--r--meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb6
3 files changed, 129 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-fixup-build-with-gcc5.patch b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-fixup-build-with-gcc5.patch
new file mode 100644
index 0000000..0c42804
--- /dev/null
+++ b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-fixup-build-with-gcc5.patch
@@ -0,0 +1,86 @@
+From ecb020204ac4207cbdfe5daa113be9a5e01ae845 Mon Sep 17 00:00:00 2001
+From: Yannick Gicquel <yannick.gicquel@iot.bzh>
+Date: Wed, 6 Jan 2016 14:33:26 +0100
+Subject: [PATCH] fixup build with gcc5
+
+Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
+---
+ include/linux/compiler-gcc5.h | 66 +++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 66 insertions(+)
+ create mode 100644 include/linux/compiler-gcc5.h
+
+diff --git a/include/linux/compiler-gcc5.h b/include/linux/compiler-gcc5.h
+new file mode 100644
+index 0000000..cdd1cc2
+--- /dev/null
++++ b/include/linux/compiler-gcc5.h
+@@ -0,0 +1,66 @@
++#ifndef __LINUX_COMPILER_H
++#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
++#endif
++
++#define __used __attribute__((__used__))
++#define __must_check __attribute__((warn_unused_result))
++#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
++
++/* Mark functions as cold. gcc will assume any path leading to a call
++ to them will be unlikely. This means a lot of manual unlikely()s
++ are unnecessary now for any paths leading to the usual suspects
++ like BUG(), printk(), panic() etc. [but let's keep them for now for
++ older compilers]
++
++ Early snapshots of gcc 4.3 don't support this and we can't detect this
++ in the preprocessor, but we can live with this because they're unreleased.
++ Maketime probing would be overkill here.
++
++ gcc also has a __attribute__((__hot__)) to move hot functions into
++ a special section, but I don't see any sense in this right now in
++ the kernel context */
++#define __cold __attribute__((__cold__))
++
++#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
++
++#ifndef __CHECKER__
++# define __compiletime_warning(message) __attribute__((warning(message)))
++# define __compiletime_error(message) __attribute__((error(message)))
++#endif /* __CHECKER__ */
++
++/*
++ * Mark a position in code as unreachable. This can be used to
++ * suppress control flow warnings after asm blocks that transfer
++ * control elsewhere.
++ *
++ * Early snapshots of gcc 4.5 don't support this and we can't detect
++ * this in the preprocessor, but we can live with this because they're
++ * unreleased. Really, we need to have autoconf for the kernel.
++ */
++#define unreachable() __builtin_unreachable()
++
++/* Mark a function definition as prohibited from being cloned. */
++#define __noclone __attribute__((__noclone__))
++
++/*
++ * Tell the optimizer that something else uses this function or variable.
++ */
++#define __visible __attribute__((externally_visible))
++
++/*
++ * GCC 'asm goto' miscompiles certain code sequences:
++ *
++ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
++ *
++ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
++ * Fixed in GCC 4.8.2 and later versions.
++ *
++ * (asm goto is automatically volatile - the naming reflects this.)
++ */
++#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
++
++#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
++#define __HAVE_BUILTIN_BSWAP32__
++#define __HAVE_BUILTIN_BSWAP64__
++#define __HAVE_BUILTIN_BSWAP16__
++#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
+--
+1.9.1
+
diff --git a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-inline-use-the-gcc-inline-version-instead-of-the-c99.patch b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-inline-use-the-gcc-inline-version-instead-of-the-c99.patch
new file mode 100644
index 0000000..8b3b22c
--- /dev/null
+++ b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot/0001-inline-use-the-gcc-inline-version-instead-of-the-c99.patch
@@ -0,0 +1,37 @@
+From 4750429f2b66036554e7667aa44a900e12f823cc Mon Sep 17 00:00:00 2001
+From: Yannick Gicquel <yannick.gicquel@iot.bzh>
+Date: Fri, 8 Jan 2016 15:40:31 +0100
+Subject: [PATCH] inline: use the gcc inline version instead of the c99 one.
+
+Workaround to build with gcc5.
+May need a further investigation.
+
+Source:
+original RFC from Jeroen Hofstee
+http://lists.denx.de/pipermail/u-boot/2014-May/180709.html
+
+Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
+---
+ include/linux/compiler-gcc.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/include/linux/compiler-gcc.h b/include/linux/compiler-gcc.h
+index 73dcf80..562e3a2 100644
+--- a/include/linux/compiler-gcc.h
++++ b/include/linux/compiler-gcc.h
+@@ -44,9 +44,9 @@
+ */
+ #if !defined(CONFIG_ARCH_SUPPORTS_OPTIMIZED_INLINING) || \
+ !defined(CONFIG_OPTIMIZE_INLINING) || (__GNUC__ < 4)
+-# define inline inline __attribute__((always_inline))
+-# define __inline__ __inline__ __attribute__((always_inline))
+-# define __inline __inline __attribute__((always_inline))
++# define inline inline __attribute__((always_inline)) __attribute__((__gnu_inline__))
++# define __inline__ __inline__ __attribute__((always_inline)) __attribute__((__gnu_inline__))
++# define __inline __inline __attribute__((always_inline)) __attribute__((__gnu_inline__))
+ #endif
+
+ #define __deprecated __attribute__((deprecated))
+--
+1.9.1
+
diff --git a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
index 8ca9e3b..d1638fa 100644
--- a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
+++ b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
@@ -18,6 +18,12 @@ S = "${WORKDIR}/git"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+# Some workaround for gcc5 support (tbc):
+SRC_URI_append = " \
+ file://0001-fixup-build-with-gcc5.patch \
+ file://0001-inline-use-the-gcc-inline-version-instead-of-the-c99.patch \
+"
+
SRC_URI_append_porter = " \
file://0001-uboot-Silk-board-support.patch \
file://0004-uboot-porter-board-support.patch \