aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2015-08-20 15:58:45 +0100
committerStephen Lawrence <stephen.lawrence@renesas.com>2015-08-20 15:58:45 +0100
commite3b0f456ba8176253cf0d289a14bf26b1ea2134a (patch)
tree91b3beea476099d773d0708a6c3f0ee52f6e022e
parentc485c9318822db060df2d3f793aec55dc8e2a2b7 (diff)
alt: mesa: Temporary workaround to upstream Mesa build issue
Temporarily disable Cortex A7 optimisation to avoid upstream build issue between YP 1.7 gcc toolchain and Mesa 10.1,x releases. The build goes away and never returns. Graphics acceleration makes no use of Mesa so there should be no performance impact. This should be removed once upstream is fixed.
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
index c7f7f28..c5b6a2d 100644
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
@@ -11,3 +11,7 @@ def map_libs(d):
MESATARGET := "${@map_libs(d)}"
include mesa-${MESATARGET}.inc
+
+# Temporarily disable Cortex A7 optimisation to avoid upstream build issue
+# between YP 1.7 gcc toolchain and Mesa 10.1,x releases.
+TARGET_CC_ARCH_remove_alt = "-mtune=cortex-a7"