aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-13 15:20:54 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-01-18 19:27:37 +0000
commitedaf53aa20cce894198295455f89bd014e2c84d5 (patch)
tree1dad8110328a5de4fa3aa382d2043150111ae353
parent64ba09ca3f79f4ebe52116af8de98d0bfbe70b49 (diff)
r-car m2: host media-ctl recipe in meta-renesas layer
media-ctl recipe existed in meta-openembedded 1.7 (dizzy) but disappeared in 2.0 (jethro) ; this breaks the build as a .bbappend cannot exist without a corresponding .bb, and is needed to build the target anyway. Host the recipe ourselves so that the build works in all cases. Chande-Id: Id97c3f9a2d5e101524018122aef45ec8782830ea Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb b/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb
new file mode 100644
index 0000000..86e5364
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Media controller control application"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
+
+DEPENDS = "linux-libc-headers"
+
+SRC_URI = "git://git.ideasonboard.org/media-ctl.git"
+SRCREV = "a6ec4a37028952ffd6e62eb52648cf66248eb519"
+
+PV = "0.0.1"
+PR = "r4"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_EXECPREFIXDIR}"
+
+PACKAGES =+ "libmediactl libv4l2subdev"
+FILES_libmediactl = "${libdir}/libmediactl${SOLIBS}"
+FILES_libv4l2subdev = "${libdir}/libv4l2subdev${SOLIBS}"
+