aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <sdx@iot.bzh>2016-01-08 14:12:11 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-01-08 14:22:35 +0000
commitcedce9ae52ea9b7518bbe8b50e8a898ee68d720c (patch)
treefc49a30b87d2c60159f1dbb8d845c2dfc135d44b
parent43e78f8a2e98921861cadad029fc30889f92c4b0 (diff)
r-car m2: do not manually populate STAGING_INCDIR, fix omx
Manually copying files to STAGING_INCDIR creates issues when rebuilding from same sstate cache but clean build directory; bitbake then detects duplicate files. Copying omx-user-module's headers to SYSROOT_DESTDIR is necessary in the same configuration, because then "/usr/local/include" will have disappeared, and gstreamer1.0-omx will complain about missing headers. Change-Id: If20ff436c04b55da7508a851a6738ddcc78c8c9f Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Author: Manuel Bachmann <mbc@iot.bzh> Author: Stephane Desneux <sdx@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
index c8623cf..01700f7 100644
--- a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
@@ -114,7 +114,6 @@ do_install() {
make install
cp -rf ${S}/OMXR/config/*.txt ${D}/usr/local/config/
cp -rf ${S}/UDF_Linux/include ${D}/usr/local/include
- cp -rf ${S}/UDF_Linux/include/*.h ${STAGING_INCDIR}
cd ${S}/OMXR/lib/
@@ -274,7 +273,6 @@ do_install() {
ln -sf libRSACPDAL_L.so.1.1 libRSACPDAL_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSACPD_ADL.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSACPD_ADL.h ${STAGING_INCDIR}
fi
if [ "X${MP3_MDW_DECODER}" = "X1" ] ; then
@@ -283,7 +281,6 @@ do_install() {
ln -sf libMP3DLA_L.so.1.4 libMP3DLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/mp3d_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/mp3d_Lib.h ${STAGING_INCDIR}
fi
if [ "X${WMA_MDW_DECODER}" = "X1" ] ; then
@@ -292,7 +289,6 @@ do_install() {
ln -sf libWMASTDLA_L.so.1.3 libWMASTDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/wmastd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/wmastd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${DDD_MDW_DECODER}" = "X1" ] ; then
@@ -301,7 +297,6 @@ do_install() {
ln -sf libRSDACDLA_L.so.1.0 libRSDACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSDACD_ADL.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSDACD_ADL.h ${STAGING_INCDIR}
fi
if [ "X${ALAC_MDW_DECODER}" = "X1" ] ; then
@@ -310,7 +305,6 @@ do_install() {
ln -sf libALACDLA_L.so.1.0 libALACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/alacd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/alacd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${FLAC_MDW_DECODER}" = "X1" ] ; then
@@ -319,7 +313,6 @@ do_install() {
ln -sf libFLACDLA_L.so.1.1 libFLACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/flacd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/flacd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${AAC_MDW_ENCODER}" = "X1" ] ; then
@@ -328,13 +321,13 @@ do_install() {
ln -sf libRSAACELA_L.so.2.1 libRSAACELA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSAACE_AAC.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSAACE_AAC.h ${STAGING_INCDIR}
fi
}
SYSROOT_PREPROCESS_FUNCS += "do_populate_share_lib"
do_populate_share_lib () {
+ sysroot_stage_dir ${D}/usr/local/include ${SYSROOT_DESTDIR}/usr/include
sysroot_stage_dir ${D}/usr/local/lib ${SYSROOT_DESTDIR}/usr/lib
}