aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-04-14 16:47:24 +0200
committerYannick Gicquel <yannick.gicquel@iot.bzh>2016-04-14 18:01:11 +0200
commitb7811b85bb65c6d39bc2e5dd45d6d1253d08105e (patch)
tree42b5ab52cc292688d857381812571ab425ecb402
parent699bd9cb1b395e6368b4e859d8f0cf8560655d8e (diff)
u-boot: move rcar-gen2 parts out of u-boot.inc
u-boot.inc is a local copy forked from poky 1.4.2. This commit move rcar-gen2 parts in main recipe. Change-Id: I74c1fc16b77b748c348c7c645b959c8b09d77904 Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
-rw-r--r--meta-rcar-gen2/recipes-bsp/u-boot/u-boot.inc14
-rw-r--r--meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb14
2 files changed, 14 insertions, 14 deletions
diff --git a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot.inc b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot.inc
index d31c3fd..adcaa6a 100644
--- a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot.inc
+++ b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot.inc
@@ -24,11 +24,6 @@ UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET ?= "all"
-# MiniMonitor requires u-boot.srec
-UBOOT_SREC ?= "u-boot.srec"
-UBOOT_SREC_SYMLINK ?= "u-boot-${MACHINE}.srec"
-UBOOT_SREC_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.srec"
-
# Some versions of u-boot build an SPL (Second Program Loader) image that
# should be packaged along with the u-boot binary as well as placed in the
# deploy directory. For those versions they can set the following variables
@@ -87,13 +82,4 @@ do_deploy () {
fi
}
-do_deploy_append() {
- install ${S}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
-
- cd ${DEPLOYDIR}
- rm -f ${UBOOT_SREC} ${UBOOT_SREC_SYMLINK}
- ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC}
- ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC_SYMLINK}
-}
-
addtask deploy before do_build after do_compile
diff --git a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
index d1638fa..69b22a3 100644
--- a/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
+++ b/meta-rcar-gen2/recipes-bsp/u-boot/u-boot_2013.01.01.bb
@@ -36,3 +36,17 @@ SRC_URI_append_silk = " \
file://0005-uboot-serial-sh-SCIF-internal-clock-support.patch \
file://0006-uboot-Silk-disable-dcache-until-fixed.patch \
"
+
+# MiniMonitor requires u-boot.srec
+UBOOT_SREC ?= "u-boot.srec"
+UBOOT_SREC_SYMLINK ?= "u-boot-${MACHINE}.srec"
+UBOOT_SREC_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.srec"
+
+do_deploy_append() {
+ install ${S}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
+
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_SREC} ${UBOOT_SREC_SYMLINK}
+ ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC}
+ ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC_SYMLINK}
+}