summaryrefslogtreecommitdiffstats
path: root/common/recipes-devtools/gcc/libgcc_4.8.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /common/recipes-devtools/gcc/libgcc_4.8.bbappend
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'common/recipes-devtools/gcc/libgcc_4.8.bbappend')
-rw-r--r--common/recipes-devtools/gcc/libgcc_4.8.bbappend38
1 files changed, 0 insertions, 38 deletions
diff --git a/common/recipes-devtools/gcc/libgcc_4.8.bbappend b/common/recipes-devtools/gcc/libgcc_4.8.bbappend
deleted file mode 100644
index 1f9888d..0000000
--- a/common/recipes-devtools/gcc/libgcc_4.8.bbappend
+++ /dev/null
@@ -1,38 +0,0 @@
-do_install_append () {
- BINVER=`${TARGET_PREFIX}gcc -dumpversion`
- if [ ${BINVER} != ${BINV} ] ; then
- rm -rf ${D}${libdir}/${TARGET_SYS}/${BINVER}/include
- SRC=${D}${libdir}/${TARGET_SYS}/${BINV}
- DEST=${D}${libdir}/${TARGET_SYS}/${BINVER}
- install -d ${SRC} ${DEST}
- for f in ${SRC}/*
- do
- cp ${f} ${DEST}
- done
- fi
-}
-
-python do_package_prepend () {
- import subprocess
- subfolder = "*crt* 64 32 x32 n32 libgcc*"
- cc = d.getVar('TARGET_PREFIX', True) + 'gcc'
- cmd = subprocess.Popen([cc, "-dumpversion"], stdout=subprocess.PIPE)
- out, err = cmd.communicate()
- version = out.split()[-1]
- binv = d.getVar('BINV', True)
- if (version != binv):
- pn = d.getVar('PN', True)
- libdir = d.getVar('libdir', True)
- targetsys = d.getVar('TARGET_SYS', True)
- appendprefix = ' ' + libdir + '/' + targetsys + '/' + version + '/'
- appends = ''
- for i in subfolder.split():
- appends = appends + appendprefix + i
- d.appendVar("FILES_" + pn + "-dev", appends)
- if bb.data.inherits_class('nativesdk', d):
- packages_libgcov = 'FILES_nativesdk-libgcov-dev'
- else:
- packages_libgcov = 'FILES_libgcov-dev'
- d.appendVar(packages_libgcov, appendprefix + "libgcov.a")
-}
-