summaryrefslogtreecommitdiffstats
path: root/common/recipes-gnome
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /common/recipes-gnome
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'common/recipes-gnome')
-rw-r--r--common/recipes-gnome/gtk+/gtk+_2.24.22.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-gnome/gtk+/gtk+_2.24.22.bbappend b/common/recipes-gnome/gtk+/gtk+_2.24.22.bbappend
new file mode 100644
index 0000000..6fc9264
--- /dev/null
+++ b/common/recipes-gnome/gtk+/gtk+_2.24.22.bbappend
@@ -0,0 +1,26 @@
+PACKAGESPLITFUNCS_prepend += " add_private_libs_packages "
+
+python add_private_libs_packages () {
+ import os
+ import re
+
+ gtk_libdir = d.expand('${libdir}/gtk-2.0/${LIBV}')
+ immodules_root = os.path.join(gtk_libdir, 'immodules')
+ printmodules_root = os.path.join(gtk_libdir, 'printbackends');
+
+ dvar = d.getVar('PKGD', True)
+
+ for dirpath, dirnames, filenames in os.walk(dvar + immodules_root):
+ for f in filenames:
+ m = re.match('^im-(.*)\.so$', f)
+ if m:
+ immodule = m.group(1)
+ d.setVar('PRIVATE_LIBS_' + 'gtk-immodule-' + immodule , 'im-' + immodule + '.so')
+
+ for dirpath, dirnames, filenames in os.walk(dvar + printmodules_root):
+ for f in filenames:
+ m = re.match('^libprintbackend-(.*)\.so$', f)
+ if m:
+ printbackend = m.group(1)
+ d.setVar('PRIVATE_LIBS_' + 'gtk-printbackend-' + printbackend , 'libprintbackend-' + printbackend + '.so')
+} \ No newline at end of file