summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch
new file mode 100644
index 0000000..4e1d59f
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0002-omxvideodec-populate-output-buffers-in-the-component.patch
@@ -0,0 +1,29 @@
+From fc7d4dec94367fcd9a3757667a10715897276c22 Mon Sep 17 00:00:00 2001
+From: Kazunori Kobayashi <kkobayas@igel.co.jp>
+Date: Wed, 5 Jun 2013 17:28:47 +0900
+Subject: [PATCH 02/14] omxvideodec: populate output buffers in the component
+
+All of the output buffers must be populated in the component with
+FillThisBuffer() beforehand so that gst_omx_video_dec_loop() waits
+for output buffers to be obtained properly.
+---
+ omx/gstomxvideodec.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
+index 7f6a48e..73f677b 100644
+--- a/omx/gstomxvideodec.c
++++ b/omx/gstomxvideodec.c
+@@ -2111,6 +2111,9 @@ gst_omx_video_dec_set_format (GstVideoDecoder * decoder,
+ if (gst_omx_component_get_state (self->dec,
+ GST_CLOCK_TIME_NONE) != OMX_StateExecuting)
+ return FALSE;
++
++ if (gst_omx_port_populate (self->dec_out_port) != OMX_ErrorNone)
++ return FALSE;
+ }
+
+ /* Unset flushing to allow ports to accept data again */
+--
+1.8.1.2
+